summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-01-25 02:15:28 +0000
committerSam James <sam@gentoo.org>2022-01-25 02:15:28 +0000
commitce97cf736d5a6de2311fcb2bf345b7ebc9f043c3 (patch)
treed3334d154be0a0bc2c823e7fb2b1dd76439f0b22 /dev-util/devhelp
parentgames-puzzle/gnome-tetravex: fix build with meson 0.61 (diff)
downloadgentoo-ce97cf736d5a6de2311fcb2bf345b7ebc9f043c3.tar.gz
gentoo-ce97cf736d5a6de2311fcb2bf345b7ebc9f043c3.tar.bz2
gentoo-ce97cf736d5a6de2311fcb2bf345b7ebc9f043c3.zip
dev-util/devhelp: fix build with meson 0.61
Closes: https://bugs.gentoo.org/831928 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/devhelp')
-rw-r--r--dev-util/devhelp/devhelp-41.2.ebuild4
-rw-r--r--dev-util/devhelp/files/41.2-meson-0.61.patch52
2 files changed, 55 insertions, 1 deletions
diff --git a/dev-util/devhelp/devhelp-41.2.ebuild b/dev-util/devhelp/devhelp-41.2.ebuild
index 0d4bb96937b5..7892dd7fcbf5 100644
--- a/dev-util/devhelp/devhelp-41.2.ebuild
+++ b/dev-util/devhelp/devhelp-41.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -45,6 +45,8 @@ BDEPEND="
PATCHES=(
"${FILESDIR}"/${PV}-optional-introspection.patch
"${FILESDIR}"/${PV}-webkitgtk40.patch
+
+ "${FILESDIR}"/${PV}-meson-0.61.patch
)
pkg_setup() {
diff --git a/dev-util/devhelp/files/41.2-meson-0.61.patch b/dev-util/devhelp/files/41.2-meson-0.61.patch
new file mode 100644
index 000000000000..dd75f802056a
--- /dev/null
+++ b/dev-util/devhelp/files/41.2-meson-0.61.patch
@@ -0,0 +1,52 @@
+https://gitlab.gnome.org/GNOME/devhelp/-/merge_requests/43.patch
+https://gitlab.gnome.org/GNOME/devhelp/-/merge_requests/42.patch
+https://bugs.gentoo.org/831928
+
+From f1c27fd4eaa59e86005f9698bb839451a2f0ef44 Mon Sep 17 00:00:00 2001
+From: r-value <i@rvalue.moe>
+Date: Wed, 17 Nov 2021 18:02:20 +0800
+Subject: [PATCH] Remove incorrect arg for i18n.merge_file
+
+`i18n.merge_file` has been ignoring positional arguments and
+explicitly rejects with error "ERROR: Function does not take
+positional arguments" since meson 0.60.0
+---
+ data/meson.build | 2 --
+ plugins/gedit-plugin/meson.build | 1 -
+ 2 files changed, 3 deletions(-)
+
+diff --git a/data/meson.build b/data/meson.build
+index c6aeffb4..0bc531a2 100644
+--- a/data/meson.build
++++ b/data/meson.build
+@@ -19,7 +19,6 @@ appdata_conf = configuration_data()
+ appdata_conf.set('application_id', APPLICATION_ID)
+ appdata = APPLICATION_ID + '.appdata.xml'
+ appdata_file = I18N.merge_file(
+- appdata,
+ input: configure_file(
+ input: 'org.gnome.Devhelp.appdata.xml.in.in',
+ output: APPLICATION_ID + '.appdata.xml.in',
+@@ -45,7 +44,6 @@ desktop_conf = configuration_data()
+ desktop_conf.set('application_id', APPLICATION_ID)
+ desktop = APPLICATION_ID + '.desktop'
+ desktop_file = I18N.merge_file(
+- desktop,
+ type: 'desktop',
+ input: configure_file(
+ input: 'org.gnome.Devhelp.desktop.in.in',
+diff --git a/plugins/gedit-plugin/meson.build b/plugins/gedit-plugin/meson.build
+index 4f779886..877a01ff 100644
+--- a/plugins/gedit-plugin/meson.build
++++ b/plugins/gedit-plugin/meson.build
+@@ -7,7 +7,6 @@ install_data(
+
+ plugin_info_file = 'devhelp.plugin'
+ I18N.merge_file(
+- plugin_info_file,
+ type: 'desktop',
+ input: plugin_info_file + '.desktop.in',
+ output: plugin_info_file,
+--
+GitLab
+