summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-03-26 19:19:09 +0200
committerJeroen Roovers <jer@gentoo.org>2018-03-26 19:19:38 +0200
commit1bf6af55eb54740e95624245e78692679e83d6ff (patch)
tree86eb71b4387de385372dc8c63d5f7fe624bc7774 /dev-util/dialog/dialog-1.3.20171209.ebuild
parentnet-libs/srt: Initial package (diff)
downloadgentoo-1bf6af55eb54740e95624245e78692679e83d6ff.tar.gz
gentoo-1bf6af55eb54740e95624245e78692679e83d6ff.tar.bz2
gentoo-1bf6af55eb54740e95624245e78692679e83d6ff.zip
dev-util/dialog: Version 1.3.20171209.
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-util/dialog/dialog-1.3.20171209.ebuild')
-rw-r--r--dev-util/dialog/dialog-1.3.20171209.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-util/dialog/dialog-1.3.20171209.ebuild b/dev-util/dialog/dialog-1.3.20171209.ebuild
new file mode 100644
index 000000000000..76110e4b945f
--- /dev/null
+++ b/dev-util/dialog/dialog-1.3.20171209.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils multilib versionator
+
+DEB_P="${PN}_$(replace_version_separator 2 '-')"
+DIA_P="${PN}-$(replace_version_separator 2 '-')"
+DESCRIPTION="tool to display dialog boxes from a shell"
+HOMEPAGE="https://invisible-island.net/dialog/dialog.html"
+SRC_URI="mirror://debian/pool/main/d/${PN}/${DEB_P}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/14"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="examples minimal nls static-libs unicode"
+
+RDEPEND="
+ >=sys-libs/ncurses-5.2-r5:=[unicode?]
+"
+DEPEND="
+ ${RDEPEND}
+ nls? ( sys-devel/gettext )
+ !minimal? ( sys-devel/libtool )
+ !<=sys-freebsd/freebsd-contrib-8.9999
+"
+S=${WORKDIR}/${DIA_P}
+
+src_prepare() {
+ default
+ sed -i -e '/LIB_CREATE=/s:${CC}:& ${LDFLAGS}:g' configure || die
+ sed -i '/$(LIBTOOL_COMPILE)/s:$: $(LIBTOOL_OPTS):' makefile.in || die
+}
+
+src_configure() {
+ econf \
+ --disable-rpath-hack \
+ $(use_enable nls) \
+ $(use_with !minimal libtool) \
+ --with-libtool-opts=$(usex static-libs '' '-shared') \
+ --with-ncurses$(usex unicode w '')
+}
+
+src_install() {
+ use minimal && default || emake DESTDIR="${D}" install-full
+
+ use examples && dodoc -r samples
+
+ dodoc CHANGES README
+
+ prune_libtool_files
+}