summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-11-14 16:04:17 +0100
committerDavid Seifert <soap@gentoo.org>2020-11-14 16:04:17 +0100
commitbd7b64ff420e97b3c4e6aa4a4cd643ef19dc6757 (patch)
tree1d9d13dfe73aee258b06a7f64560e7c96409cc54 /dev-util/diffball
parentapp-arch/fastjar: Port to EAPI 7 (diff)
downloadgentoo-bd7b64ff420e97b3c4e6aa4a4cd643ef19dc6757.tar.gz
gentoo-bd7b64ff420e97b3c4e6aa4a4cd643ef19dc6757.tar.bz2
gentoo-bd7b64ff420e97b3c4e6aa4a4cd643ef19dc6757.zip
dev-util/diffball: Remove libtool archives
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-util/diffball')
-rw-r--r--dev-util/diffball/diffball-1.0.1-r2.ebuild22
1 files changed, 16 insertions, 6 deletions
diff --git a/dev-util/diffball/diffball-1.0.1-r2.ebuild b/dev-util/diffball/diffball-1.0.1-r2.ebuild
index 315c3c7a4696..789ab5f84495 100644
--- a/dev-util/diffball/diffball-1.0.1-r2.ebuild
+++ b/dev-util/diffball/diffball-1.0.1-r2.ebuild
@@ -16,18 +16,19 @@ SLOT="0"
KEYWORDS="~alpha amd64 ~hppa ~ia64 ~mips ppc ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
IUSE="debug"
-RDEPEND=">=sys-libs/zlib-1.1.4
+RDEPEND="
+ >=sys-libs/zlib-1.1.4
>=app-arch/bzip2-1.0.2
app-arch/xz-utils"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
# Invalid RESTRICT for source package. Investigate.
RESTRICT="strip"
PATCHES=(
- "${DISTDIR}/${P}-bug_543310_stack_buffer_overflows.patch"
- "${DISTDIR}/${P}-bug_708736_cseek_xz_reset_avail_in_out.patch"
+ "${DISTDIR}"/${P}-bug_543310_stack_buffer_overflows.patch
+ "${DISTDIR}"/${P}-bug_708736_cseek_xz_reset_avail_in_out.patch
)
src_prepare() {
@@ -38,5 +39,14 @@ src_prepare() {
}
src_configure() {
- econf --disable-static $(use_enable debug asserts)
+ econf \
+ --disable-static \
+ $(use_enable debug asserts)
+}
+
+src_install() {
+ default
+
+ # no static archives
+ find "${ED}" -name '*.la' -delete || die
}