summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2021-06-12 16:10:20 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2021-06-12 16:10:23 +0100
commit12180e0d3e9d3ffca7d1afb48384455e9b63fe1c (patch)
tree3e6e7ac841d309c1d484feb741b4f3d581954877 /dev-util/diffoscope
parentx11-misc/xscreensaver: Drop Glade dependency (diff)
downloadgentoo-12180e0d3e9d3ffca7d1afb48384455e9b63fe1c.tar.gz
gentoo-12180e0d3e9d3ffca7d1afb48384455e9b63fe1c.tar.bz2
gentoo-12180e0d3e9d3ffca7d1afb48384455e9b63fe1c.zip
dev-util/diffoscope: disable broken tests
Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-util/diffoscope')
-rw-r--r--dev-util/diffoscope/diffoscope-177.ebuild14
1 files changed, 14 insertions, 0 deletions
diff --git a/dev-util/diffoscope/diffoscope-177.ebuild b/dev-util/diffoscope/diffoscope-177.ebuild
index 2fd7602fa6d2..9ae8834c67c7 100644
--- a/dev-util/diffoscope/diffoscope-177.ebuild
+++ b/dev-util/diffoscope/diffoscope-177.ebuild
@@ -73,3 +73,17 @@ RDEPEND="dev-python/python-magic[${PYTHON_USEDEP}]
RDEPEND+=" !dev-python/filemagic"
distutils_enable_tests pytest
+
+python_test() {
+ local exclude=(
+ # test seems to use different tarball
+ tests/test_presenters.py::test_text_proper_indentation
+
+ # needs triage
+ tests/comparators/test_binary.py::test_with_compare_details_and_tool_not_found
+
+ # needs triage
+ tests/comparators/test_rlib.py::test_item3_deflate_llvm_bitcode
+ )
+ epytest ${exclude[@]/#/--deselect }
+}