summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-09-11 06:43:40 +0100
committerSam James <sam@gentoo.org>2021-09-11 06:44:21 +0100
commit8f4fd0e6086b5e4f9f89e08d084e4deccd9416d1 (patch)
treee10749ab1927d66f89cb2fdd286becfe7a27c3f5 /dev-util/diffoscope
parentdev-python/async-lru: enable py3.10, EAPI=8, up pytest dep (diff)
downloadgentoo-8f4fd0e6086b5e4f9f89e08d084e4deccd9416d1.tar.gz
gentoo-8f4fd0e6086b5e4f9f89e08d084e4deccd9416d1.tar.bz2
gentoo-8f4fd0e6086b5e4f9f89e08d084e4deccd9416d1.zip
dev-util/diffoscope: add 183
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/diffoscope')
-rw-r--r--dev-util/diffoscope/Manifest1
-rw-r--r--dev-util/diffoscope/diffoscope-183.ebuild112
2 files changed, 113 insertions, 0 deletions
diff --git a/dev-util/diffoscope/Manifest b/dev-util/diffoscope/Manifest
index 93e5d704151a..591d9da63523 100644
--- a/dev-util/diffoscope/Manifest
+++ b/dev-util/diffoscope/Manifest
@@ -2,3 +2,4 @@ DIST diffoscope-177.tar.gz 1590984 BLAKE2B 94daf9528c8fd0ad6ed89bdbee7b21352bf33
DIST diffoscope-180.tar.gz 1600542 BLAKE2B 0cc34106f039e0682b32de284b3ce1be90e8629fb4ba18cffa31d7c970a9d18392060f37b201d4ee9ab3f4f65401684c72edf2d00d56827cbaacbfde0ce81d11 SHA512 abf2c514b9f3b074a5b9a6e19f09a474a8ba58e00974a48ebd860cc31547204fb4690224cb752b4248a0674d979bd20c6d4c77ffb912f2b85499d48d90affeb4
DIST diffoscope-181.tar.gz 1602420 BLAKE2B ae5f40b7a687c6425444df816b0583e50a0c86a4c31b44034a365c18e448765587a093794d3aab930b979706655a661a3cd8b398e34604c7f3e556a9f918406d SHA512 de4132b936ce6c79e333ab5c835f4dfe30951fc91b70848f9ecc91cb5323b81a47fa25a6cec562cfd3d059d96809bd85dbe1b37971fffdc15303ac504514759a
DIST diffoscope-182.tar.gz 1602751 BLAKE2B 0039dd91d5f6653cd2addb0193d9070e53fd785ace64ca11a2ffe80078ff07a43deba6ee4c16f29d9152d18130fc793a48086fba48ce0d60861f0bf71d1c375e SHA512 86333b443c18e6ec809742707d7242deb4977a20e2d864a873519120fb0fe0504a3198cc0f2ff66d6101182bdfd998a96a260a75da710c3ef43a1220c7126897
+DIST diffoscope-183.tar.gz 1603189 BLAKE2B ccfacfe7fb2dc8259328360378cb88976124ec793a1aebf7e8512da4d2b4869e89a4941c2e8adfc49dbe6a2c26afc3444de63b5a598f2c9fbc455f74adca6b37 SHA512 868c3cd13e49505a18487d9084c4e560665cd3253091f68c454fccc0e560fe189c875628a1a1064d2cb988afe66a44de2863c55a9e19459de032923572673e38
diff --git a/dev-util/diffoscope/diffoscope-183.ebuild b/dev-util/diffoscope/diffoscope-183.ebuild
new file mode 100644
index 000000000000..086eecc95294
--- /dev/null
+++ b/dev-util/diffoscope/diffoscope-183.ebuild
@@ -0,0 +1,112 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8,9,10} )
+PYTHON_REQ_USE="ncurses"
+
+inherit distutils-r1
+
+DESCRIPTION="Will try to get to the bottom of what makes files or directories different"
+HOMEPAGE="https://diffoscope.org/ https://pypi.org/project/diffoscope/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="acl binutils bzip2 libcaca colord cpio +diff docx dtc e2fsprogs file
+find gettext gif gpg haskell hdf5 hex imagemagick iso java llvm lzma
+mono opendocument pascal pdf postscript R rpm sqlite squashfs
+ssh tar test tcpdump zip zlib zstd"
+
+RESTRICT="!test? ( test )"
+
+# pull in optional tools for tests:
+# img2txt: bug #797688
+# docx2txt: bug #797688
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ app-text/docx2txt
+ media-libs/libcaca
+ )
+"
+RDEPEND="dev-python/python-magic[${PYTHON_USEDEP}]
+ dev-python/libarchive-c[${PYTHON_USEDEP}]
+ dev-python/distro[${PYTHON_USEDEP}]
+ acl? ( sys-apps/acl )
+ binutils? ( sys-devel/binutils )
+ bzip2? ( app-arch/bzip2 )
+ libcaca? ( media-libs/libcaca )
+ colord? ( x11-misc/colord )
+ cpio? ( app-arch/cpio )
+ diff? ( sys-apps/diffutils )
+ docx? ( app-text/docx2txt )
+ dtc? ( sys-apps/dtc )
+ e2fsprogs? ( sys-fs/e2fsprogs )
+ file? ( sys-apps/file )
+ find? ( sys-apps/findutils )
+ gettext? ( sys-devel/gettext )
+ gif? ( media-libs/giflib )
+ gpg? ( app-crypt/gnupg )
+ haskell? ( dev-lang/ghc )
+ hdf5? ( sci-libs/hdf5 )
+ hex? ( app-editors/vim-core )
+ imagemagick? ( media-gfx/imagemagick )
+ iso? ( app-cdr/cdrtools )
+ java? ( virtual/jdk )
+ llvm? ( sys-devel/llvm )
+ lzma? ( app-arch/xz-utils )
+ mono? ( dev-lang/mono )
+ opendocument? ( app-text/odt2txt )
+ pascal? ( dev-lang/fpc )
+ pdf? (
+ app-text/pdftk
+ app-text/poppler
+ dev-python/PyPDF2[${PYTHON_USEDEP}]
+ )
+ postscript? ( app-text/ghostscript-gpl )
+ R? ( dev-lang/R )
+ rpm? ( app-arch/rpm )
+ sqlite? ( dev-db/sqlite:3 )
+ squashfs? ( sys-fs/squashfs-tools )
+ ssh? ( net-misc/openssh )
+ tar? ( app-arch/tar )
+ tcpdump? ( net-analyzer/tcpdump )
+ zip? ( app-arch/unzip )
+ zlib? ( app-arch/gzip )
+ zstd? ( app-arch/zstd )
+"
+# Presence if filemagic's magic.py breaks imports
+# of dev-python/python-magic: https://bugs.gentoo.org/716482
+RDEPEND+=" !dev-python/filemagic"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local exclude=(
+ # test seems to use different tarball
+ tests/test_presenters.py::test_text_proper_indentation
+
+ # needs triage
+ tests/comparators/test_binary.py::test_with_compare_details_and_tool_not_found
+
+ # needs triage
+ tests/comparators/test_rlib.py::test_item3_deflate_llvm_bitcode
+
+ # img2txt based failures, bug #797688
+ tests/comparators/test_ico_image.py::test_diff
+ tests/comparators/test_ico_image.py::test_diff_meta
+ tests/comparators/test_ico_image.py::test_diff_meta2
+ tests/comparators/test_ico_image.py::test_has_visuals
+ tests/comparators/test_jpeg_image.py::test_diff
+ tests/comparators/test_jpeg_image.py::test_compare_non_existing
+ tests/comparators/test_jpeg_image.py::test_diff_meta
+ tests/comparators/test_jpeg_image.py::test_has_visuals
+
+ # docx2txt based falures, bug #797688
+ tests/comparators/test_docx.py::test_diff
+ )
+ epytest ${exclude[@]/#/--deselect }
+}