summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-07-21 14:16:34 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-07-21 14:16:34 +0200
commit71c859fff5d5a13682882b13e3771935564b1369 (patch)
tree38ecc460b485155dc48659e416fea7b1ebf513ce /dev-util/drone-cli/drone-cli-0.7.0_p20170717.ebuild
parentdev-util/drone-cli: Remove old (diff)
downloadgentoo-71c859fff5d5a13682882b13e3771935564b1369.tar.gz
gentoo-71c859fff5d5a13682882b13e3771935564b1369.tar.bz2
gentoo-71c859fff5d5a13682882b13e3771935564b1369.zip
dev-util/drone-cli: Update snapshot
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-util/drone-cli/drone-cli-0.7.0_p20170717.ebuild')
-rw-r--r--dev-util/drone-cli/drone-cli-0.7.0_p20170717.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-util/drone-cli/drone-cli-0.7.0_p20170717.ebuild b/dev-util/drone-cli/drone-cli-0.7.0_p20170717.ebuild
new file mode 100644
index 000000000000..9133bfec3093
--- /dev/null
+++ b/dev-util/drone-cli/drone-cli-0.7.0_p20170717.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGO_PN="github.com/drone/drone-cli"
+EGIT_COMMIT="4a5e8a2acb2c82c5a4e6b96b6849f59962dfb668"
+
+inherit golang-build golang-vcs-snapshot
+
+ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Command-line interface for Drone"
+HOMEPAGE="https://github.com/drone/drone-cli"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+RESTRICT="test"
+
+RDEPEND="!!<dev-util/drone-0.7"
+
+src_compile() {
+ pushd src || die
+ GOPATH="${WORKDIR}/${P}"\
+ go install -ldflags "-X main.version=${PV}.${EGIT_COMMIT:0:7}" ${EGO_PN}/drone || die
+ popd || die
+}
+
+src_install() {
+ dobin bin/drone
+ dodoc src/${EGO_PN}/README.md
+}