summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2018-08-21 07:17:24 +0200
committerMatthias Schwarzott <zzam@gentoo.org>2018-08-21 20:16:41 +0200
commita792f2f250de5e913663262d0a4aa4964b8db256 (patch)
treeedfe3333c6214c757b64e65c610551371f9de2a3 /dev-util/dwarves/dwarves-1.12.ebuild
parentnet-wireless/gr-ieee802154: add snapshot (diff)
downloadgentoo-a792f2f250de5e913663262d0a4aa4964b8db256.tar.gz
gentoo-a792f2f250de5e913663262d0a4aa4964b8db256.tar.bz2
gentoo-a792f2f250de5e913663262d0a4aa4964b8db256.zip
dev-util/dwarves: Version bump to 1.12 and use EAPI 6
Package-Manager: Portage-2.3.47, Repoman-2.3.10
Diffstat (limited to 'dev-util/dwarves/dwarves-1.12.ebuild')
-rw-r--r--dev-util/dwarves/dwarves-1.12.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-util/dwarves/dwarves-1.12.ebuild b/dev-util/dwarves/dwarves-1.12.ebuild
new file mode 100644
index 000000000000..13d4797c399f
--- /dev/null
+++ b/dev-util/dwarves/dwarves-1.12.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+inherit multilib cmake-utils python-single-r1
+
+DESCRIPTION="pahole (Poke-a-Hole) and other DWARF2 utilities"
+HOMEPAGE="https://git.kernel.org/cgit/devel/pahole/pahole.git/"
+
+LICENSE="GPL-2" # only
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ >=dev-libs/elfutils-0.131
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+if [[ ${PV//_p} == ${PV} ]]; then
+ SRC_URI="http://fedorapeople.org/~acme/dwarves/${P}.tar.bz2"
+ S=${WORKDIR}
+else
+ SRC_URI="https://dev.gentoo.org/~zzam/${PN}/${P}.tar.xz"
+fi
+
+DOCS=( README README.ctracer NEWS )
+PATCHES=( "${FILESDIR}"/${PN}-1.10-python-import.patch )
+
+src_configure() {
+ local mycmakeargs=( "-D__LIB=$(get_libdir)" )
+ cmake-utils_src_configure
+}
+
+src_test() { :; }
+
+src_install() {
+ cmake-utils_src_install
+ python_fix_shebang "${D}"/usr/bin/ostra-cg \
+ "${D}"/usr/share/dwarves/runtime/python/ostra.py
+}