summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2020-03-15 11:52:29 +0100
committerMatthias Schwarzott <zzam@gentoo.org>2020-03-15 11:53:13 +0100
commitf2c99a121c14d93ca43e5379f12bb96a4cd38dd2 (patch)
tree65a4a4b00cd4fa127fa53b98aca46812a23b7b7b /dev-util/dwarves/dwarves-1.17.ebuild
parentnet-print/cups: Security cleanup (diff)
downloadgentoo-f2c99a121c14d93ca43e5379f12bb96a4cd38dd2.tar.gz
gentoo-f2c99a121c14d93ca43e5379f12bb96a4cd38dd2.tar.bz2
gentoo-f2c99a121c14d93ca43e5379f12bb96a4cd38dd2.zip
dev-util/dwarves: Version bumped.
One patch got included. Source dir did change. Package-Manager: Portage-2.3.93, Repoman-2.3.20 Signed-off-by: Matthias Schwarzott <zzam@gentoo.org>
Diffstat (limited to 'dev-util/dwarves/dwarves-1.17.ebuild')
-rw-r--r--dev-util/dwarves/dwarves-1.17.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-util/dwarves/dwarves-1.17.ebuild b/dev-util/dwarves/dwarves-1.17.ebuild
new file mode 100644
index 000000000000..0f8e99442d3d
--- /dev/null
+++ b/dev-util/dwarves/dwarves-1.17.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_6 )
+inherit multilib cmake-utils python-single-r1
+
+DESCRIPTION="pahole (Poke-a-Hole) and other DWARF2 utilities"
+HOMEPAGE="https://git.kernel.org/cgit/devel/pahole/pahole.git/"
+
+LICENSE="GPL-2" # only
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ >=dev-libs/elfutils-0.178
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+if [[ ${PV//_p} == ${PV} ]]; then
+ SRC_URI="http://fedorapeople.org/~acme/dwarves/${P}.tar.xz"
+else
+ SRC_URI="https://dev.gentoo.org/~zzam/${PN}/${P}.tar.xz"
+fi
+
+DOCS=( README README.ctracer NEWS )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.10-python-import.patch
+)
+
+src_configure() {
+ local mycmakeargs=( "-D__LIB=$(get_libdir)" )
+ cmake-utils_src_configure
+}
+
+src_test() { :; }
+
+src_install() {
+ cmake-utils_src_install
+}