summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-12-07 18:00:01 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2019-12-07 18:00:01 +0000
commit58252a6ffe48778d7dcfd2ca86894dac68f7e4ce (patch)
treee25e6c464662ec4d47fe354ccfb5c86ba57b2632 /dev-util/edb-debugger
parentapp-forensics/honggfuzz: drop old (diff)
downloadgentoo-58252a6ffe48778d7dcfd2ca86894dac68f7e4ce.tar.gz
gentoo-58252a6ffe48778d7dcfd2ca86894dac68f7e4ce.tar.bz2
gentoo-58252a6ffe48778d7dcfd2ca86894dac68f7e4ce.zip
dev-util/edb-debugger: fix manpage install path, bug #701080
While at it mode to EAPI=7 Closes: https://bugs.gentoo.org/701080 Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-util/edb-debugger')
-rw-r--r--dev-util/edb-debugger/edb-debugger-1.0.0-r3.ebuild48
-rw-r--r--dev-util/edb-debugger/files/edb-debugger-1.0.0-man1.patch21
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-util/edb-debugger/edb-debugger-1.0.0-r3.ebuild b/dev-util/edb-debugger/edb-debugger-1.0.0-r3.ebuild
new file mode 100644
index 000000000000..97f78c594bee
--- /dev/null
+++ b/dev-util/edb-debugger/edb-debugger-1.0.0-r3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="edb is a cross platform x86/x86-64 debugger, inspired by Ollydbg"
+HOMEPAGE="https://github.com/eteran/edb-debugger"
+SRC_URI="https://github.com/eteran/edb-debugger/releases/download/${PV}/edb-debugger-${PV}.tgz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="graphviz"
+
+RDEPEND="
+ dev-libs/capstone:=
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ dev-qt/qtxmlpatterns:5
+ graphviz? ( media-gfx/graphviz )
+"
+
+DEPEND="
+ dev-libs/boost
+ virtual/pkgconfig
+ ${RDEPEND}
+"
+
+PATCHES=("${FILESDIR}"/${P}-man1.patch)
+
+src_prepare() {
+ #Make the desktop's entries somewhat better
+ sed -i -e 's/GenericName=edb debugger/GenericName=Evan\x27s Debugger/' edb.desktop || die
+ sed -i -e 's/Comment=edb debugger/Comment=edb is a cross platform x86\/x86-64 debugger/' edb.desktop || die
+
+ if ! use graphviz; then
+ sed -i -e '/pkg_check_modules(GRAPHVIZ/d' CMakeLists.txt || die
+ fi
+
+ cmake-utils_src_prepare
+}
diff --git a/dev-util/edb-debugger/files/edb-debugger-1.0.0-man1.patch b/dev-util/edb-debugger/files/edb-debugger-1.0.0-man1.patch
new file mode 100644
index 000000000000..92625ac3701a
--- /dev/null
+++ b/dev-util/edb-debugger/files/edb-debugger-1.0.0-man1.patch
@@ -0,0 +1,21 @@
+https://bugs.gentoo.org/701080
+
+From c84c5a28adaacaeee65a20e1bd8a90762cbe843c Mon Sep 17 00:00:00 2001
+From: Ruslan Kabatsayev <b7.10110111@gmail.com>
+Date: Thu, 5 Jul 2018 23:45:03 +0300
+Subject: [PATCH] Fix installation path of the man page
+
+---
+ CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -123,6 +123,6 @@ endif()
+ add_subdirectory(src)
+ add_subdirectory(plugins)
+
+-install (FILES ${CMAKE_SOURCE_DIR}/edb.1 DESTINATION ${CMAKE_INSTALL_MANDIR})
++install (FILES ${CMAKE_SOURCE_DIR}/edb.1 DESTINATION ${CMAKE_INSTALL_MANDIR}/man1)
+ install (FILES ${CMAKE_SOURCE_DIR}/edb.desktop DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/applications/)
+ install (FILES ${CMAKE_SOURCE_DIR}/src/images/edb.png DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/pixmaps/)