summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/elfkickers/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/elfkickers/files')
-rw-r--r--dev-util/elfkickers/files/add-freebsd-elf-defs.patch68
-rw-r--r--dev-util/elfkickers/files/create-destdir-path.patch14
-rw-r--r--dev-util/elfkickers/files/respect-CFLAGS-LDFLAGS.patch102
3 files changed, 184 insertions, 0 deletions
diff --git a/dev-util/elfkickers/files/add-freebsd-elf-defs.patch b/dev-util/elfkickers/files/add-freebsd-elf-defs.patch
new file mode 100644
index 000000000000..792a91d6dfb2
--- /dev/null
+++ b/dev-util/elfkickers/files/add-freebsd-elf-defs.patch
@@ -0,0 +1,68 @@
+--- ./elfrw/elfrw.h.orig 2011-05-31 01:47:08.000000000 +0200
++++ ./elfrw/elfrw.h 2011-06-08 12:16:37.000000000 +0200
+@@ -10,6 +10,24 @@
+ #include <stdio.h>
+ #include <elf.h>
+
++#ifdef __FreeBSD__
++typedef uint16_t Elf64_Section;
++
++#define PT_GNU_STACK 0x6474e551
++#define PT_GNU_RELRO 0x6474e552
++
++#if __FreeBSD_version < 700022
++#define SHT_GNU_HASH 0x6ffffff6
++#define EM_CRIS 76
++#define EM_M32R 88
++#define EM_MN10300 89
++#endif
++
++#define ELFCLASSNUM 3
++#define ELFDATANUM 3
++#define EV_NUM 2
++#endif
++
+ /*
+ * The initialization functions. Call one of these to set the flavor
+ * of ELF structures to translate to and from. The library can be
+--- ./elftoc/readelf.h.orig 2011-05-22 20:46:29.000000000 +0200
++++ ./elftoc/readelf.h 2011-06-08 12:16:37.000000000 +0200
+@@ -7,6 +7,12 @@
+ #ifndef _readelf_h_
+ #define _readelf_h_
+
++#ifdef __FreeBSD__
++#define ELFCLASSNUM 3
++#define ELFDATANUM 3
++#define EV_NUM 2
++#endif
++
+ /* Read all of the basic headers from the file image (namely the ELF
+ * header, the program segment header table, and the section header
+ * table). False is returned if the file could not be parsed as an ELF
+--- ./elftoc/pieces.c.orig 2011-05-26 03:25:14.000000000 +0200
++++ ./elftoc/pieces.c 2011-06-08 12:16:37.000000000 +0200
+@@ -16,6 +16,10 @@
+ #include "out.h"
+ #include "pieces.h"
+
++#ifdef __FreeBSD__
++typedef uint64_t Elf32_Xword;
++#endif
++
+ /* Flags used to insert warnings in the generated source code.
+ */
+ #define PW_MISALIGNED 0x0001 /* piece misaligned for original type */
+--- ./elftoc/outbase.h.orig 2011-05-22 20:46:29.000000000 +0200
++++ ./elftoc/outbase.h 2011-06-08 12:16:37.000000000 +0200
+@@ -7,6 +7,10 @@
+ #ifndef _outbase_h_
+ #define _outbase_h_
+
++#ifdef __FreeBSD__
++#define NT_AUXV 6
++#endif
++
+ /* Set the current output file. Call this before calling any output
+ * functions. (The FILE* argument is given as a void* so as to not
+ * include stdio.h here.)
diff --git a/dev-util/elfkickers/files/create-destdir-path.patch b/dev-util/elfkickers/files/create-destdir-path.patch
new file mode 100644
index 000000000000..d279db0ad606
--- /dev/null
+++ b/dev-util/elfkickers/files/create-destdir-path.patch
@@ -0,0 +1,14 @@
+--- Makefile.orig 2011-05-30 16:37:41.000000000 -0400
++++ Makefile 2011-05-30 16:38:30.000000000 -0400
+@@ -22,8 +22,9 @@
+ infect: bin/infect doc/infect.1
+
+ install: $(PROGRAMS:%=bin/%)
+- cp bin/* $(prefix)/bin/.
+- cp doc/* $(prefix)/share/man/man1/.
++ install -d $(prefix)/usr/bin $(prefix)/usr/share/man/man1
++ install bin/* $(prefix)/usr/bin
++ install -m 644 doc/* $(prefix)/usr/share/man/man1
+
+ clean:
+ for dir in elfrw $(PROGRAMS) ; do $(MAKE) -C$$dir clean ; done
diff --git a/dev-util/elfkickers/files/respect-CFLAGS-LDFLAGS.patch b/dev-util/elfkickers/files/respect-CFLAGS-LDFLAGS.patch
new file mode 100644
index 000000000000..6663ef8e79af
--- /dev/null
+++ b/dev-util/elfkickers/files/respect-CFLAGS-LDFLAGS.patch
@@ -0,0 +1,102 @@
+diff -Naur ELFkickers-3.0.orig//ebfc/Makefile ELFkickers-3.0/ebfc/Makefile
+--- ELFkickers-3.0.orig//ebfc/Makefile 2011-05-24 00:51:07.000000000 -0400
++++ ELFkickers-3.0/ebfc/Makefile 2011-06-02 23:05:30.000000000 -0400
+@@ -1,7 +1,7 @@
+ # Makefile for ebfc
+
+-CC = gcc
+-CFLAGS = -Wall -Wextra -Wno-missing-field-initializers
++CC ?= gcc
++CFLAGS += -Wno-missing-field-initializers
+
+ ebfc: ebfc.o brainfuck.o libelfparts.a
+
+diff -Naur ELFkickers-3.0.orig//elfls/Makefile ELFkickers-3.0/elfls/Makefile
+--- ELFkickers-3.0.orig//elfls/Makefile 2011-05-31 02:53:05.000000000 -0400
++++ ELFkickers-3.0/elfls/Makefile 2011-06-02 23:04:15.000000000 -0400
+@@ -1,7 +1,7 @@
+ # Makefile for elfls
+
+-CC = gcc
+-CFLAGS = -Wall -Wextra -I../elfrw
++CC ?= gcc
++CFLAGS += -I../elfrw
+
+ elfls: elfls.c ../elfrw/libelfrw.a
+
+diff -Naur ELFkickers-3.0.orig//elfrw/Makefile ELFkickers-3.0/elfrw/Makefile
+--- ELFkickers-3.0.orig//elfrw/Makefile 2011-05-22 14:02:12.000000000 -0400
++++ ELFkickers-3.0/elfrw/Makefile 2011-06-02 23:04:37.000000000 -0400
+@@ -1,7 +1,6 @@
+ # Makefile for libelfrw.a
+
+-CC = gcc
+-CFLAGS = -Wall -Wextra -O3
++CC ?= gcc
+
+ LIBOBJS = elfrw.o elfrw_dyn.o elfrw_ehdr.o elfrw_phdr.o elfrw_rel.o \
+ elfrw_shdr.o elfrw_sym.o elfrw_ver.o
+diff -Naur ELFkickers-3.0.orig//elftoc/Makefile ELFkickers-3.0/elftoc/Makefile
+--- ELFkickers-3.0.orig//elftoc/Makefile 2011-05-23 23:30:22.000000000 -0400
++++ ELFkickers-3.0/elftoc/Makefile 2011-06-02 23:04:27.000000000 -0400
+@@ -1,8 +1,6 @@
+ # Makefile for elftoc
+
+-CC = gcc
+-CFLAGS = -Wall -Wextra
+-LDFLAGS = -Wall -Wextra
++CC ?= gcc
+
+ OBJS = gen.o names.o address.o readelf.o shdrtab.o phdrtab.o dynamic.o \
+ pieces.o outbase.o outitems.o outelf64.o outelf32.o out.o elftoc.o
+diff -Naur ELFkickers-3.0.orig//infect/Makefile ELFkickers-3.0/infect/Makefile
+--- ELFkickers-3.0.orig//infect/Makefile 2011-05-31 02:52:27.000000000 -0400
++++ ELFkickers-3.0/infect/Makefile 2011-06-02 23:04:01.000000000 -0400
+@@ -1,7 +1,6 @@
+ # Makefile for infect
+
+-CC = gcc
+-CFLAGS = -Wall -Wextra
++CC ?= gcc
+
+ infect: infect.c
+
+diff -Naur ELFkickers-3.0.orig//objres/Makefile ELFkickers-3.0/objres/Makefile
+--- ELFkickers-3.0.orig//objres/Makefile 2011-05-23 23:29:39.000000000 -0400
++++ ELFkickers-3.0/objres/Makefile 2011-06-02 23:05:08.000000000 -0400
+@@ -1,7 +1,7 @@
+ # Makefile for objres
+
+-CC = gcc
+-CFLAGS = -Wall -Wextra -I../elfrw
++CC ?= gcc
++CFLAGS += -I../elfrw
+
+ objres: objres.c ../elfrw/libelfrw.a
+
+diff -Naur ELFkickers-3.0.orig//rebind/Makefile ELFkickers-3.0/rebind/Makefile
+--- ELFkickers-3.0.orig//rebind/Makefile 2011-05-23 23:29:16.000000000 -0400
++++ ELFkickers-3.0/rebind/Makefile 2011-06-02 23:04:57.000000000 -0400
+@@ -1,7 +1,7 @@
+ # Makefile for rebind
+
+-CC = gcc
+-CFLAGS = -Wall -Wextra -I../elfrw
++CC ?= gcc
++CFLAGS += -I../elfrw
+
+ rebind: rebind.c ../elfrw/libelfrw.a
+
+diff -Naur ELFkickers-3.0.orig//sstrip/Makefile ELFkickers-3.0/sstrip/Makefile
+--- ELFkickers-3.0.orig//sstrip/Makefile 2011-05-23 23:29:58.000000000 -0400
++++ ELFkickers-3.0/sstrip/Makefile 2011-06-02 23:05:41.000000000 -0400
+@@ -1,7 +1,7 @@
+ # Makefile for sstrip
+
+-CC = gcc
+-CFLAGS = -Wall -Wextra -I../elfrw
++CC ?= gcc
++CFLAGS += -I../elfrw
+
+ sstrip: sstrip.c ../elfrw/libelfrw.a
+