summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/emilpro
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/emilpro')
-rw-r--r--dev-util/emilpro/Manifest2
-rw-r--r--dev-util/emilpro/emilpro-3-r1.ebuild58
-rw-r--r--dev-util/emilpro/emilpro-9999.ebuild57
-rw-r--r--dev-util/emilpro/files/respect-cflags.patch12
-rw-r--r--dev-util/emilpro/files/use-gentoo-binutils.patch36
-rw-r--r--dev-util/emilpro/metadata.xml13
6 files changed, 178 insertions, 0 deletions
diff --git a/dev-util/emilpro/Manifest b/dev-util/emilpro/Manifest
new file mode 100644
index 000000000000..4f2ccc1add09
--- /dev/null
+++ b/dev-util/emilpro/Manifest
@@ -0,0 +1,2 @@
+DIST binutils-2.23.2.tar.bz2 21440347 SHA256 fe914e56fed7a9ec2eb45274b1f2e14b0d8b4f41906a5194eac6883cfe5c1097 SHA512 dec753bbba008f1526b89cf1bd85feba78f362f5333ffdf93953fd131eb755976dec82a0a4ba38c43d2434da007137780cfe674de5414be5cf7ce7fbc6af6d16 WHIRLPOOL 1be65f03569d599899c5b57ac7aedbf90b311f9a47c1883dc62c0717b0757ebfb33e17ab3def8d0b805daabba67cf554463f88675c9f552a6fd8dbe7ca77b442
+DIST emilpro-3.tar.gz 120276 SHA256 6c4cf5d7debcc19a87bc61682d3adee4e2d1cdec2a06570f203130d6cf917748 SHA512 18a90dd672a4fb878f0da1eefacb01f159e25b28c94ea6707578deab74dbf07ee0f9d276e376f4eaff7b00c4dd7edcf5b7cbb3e5b316f4d720fe0343e1c36727 WHIRLPOOL d484f6860118db921736001982461ad5410cdf63aca21c9896e9bbe17fdb693f7debd53282fca61d085f405c1d701af99bfcd12b2cc554ddc11607b98977262a
diff --git a/dev-util/emilpro/emilpro-3-r1.ebuild b/dev-util/emilpro/emilpro-3-r1.ebuild
new file mode 100644
index 000000000000..4a2cab3b7345
--- /dev/null
+++ b/dev-util/emilpro/emilpro-3-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils eutils
+
+DESCRIPTION="a graphical disassembler for a large number of instruction sets"
+HOMEPAGE="http://www.emilpro.com/"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/SimonKagstrom/emilpro"
+ inherit git-r3
+ KEYWORDS=""
+ SRC_URI="mirror://gnu/binutils/binutils-2.23.2.tar.bz2"
+else
+ SRC_URI="http://www.emilpro.com/${P}.tar.gz
+ !system-binutils? ( mirror://gnu/binutils/binutils-2.23.2.tar.bz2 )"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+system-binutils"
+
+DEPEND="|| ( dev-libs/elfutils dev-libs/libelf )
+ dev-cpp/gtkmm:3.0
+ dev-cpp/gtksourceviewmm:3.0
+ dev-cpp/libxmlpp:2.6
+ system-binutils? ( sys-devel/binutils[multitarget] )
+ net-misc/curl"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/respect-cflags.patch
+ if use system-binutils; then
+ epatch "${FILESDIR}"/use-gentoo-binutils.patch
+ else
+ sed -i "s#wget -O binutils.tar.bz2 http://ftp.gnu.org/gnu/binutils/binutils-2.23.2.tar.bz2#cp \"${DISTDIR}/binutils-2.23.2.tar.bz2\" ./binutils.tar.bz2#" cmake/BuildBinutils.cmake
+ fi
+ cmake-utils_src_prepare
+}
+
+src_compile() {
+ if use system-binutils; then
+ cmake-utils_src_compile
+ else
+ #bundled binutils is broken, always builds with one thread
+ #but somehow it still fails if I don't do this
+ cd "${BUILD_DIR}"
+ emake -j1
+ fi
+}
+
+src_install() {
+ dobin "${BUILD_DIR}"/emilpro
+}
diff --git a/dev-util/emilpro/emilpro-9999.ebuild b/dev-util/emilpro/emilpro-9999.ebuild
new file mode 100644
index 000000000000..c0d05005014a
--- /dev/null
+++ b/dev-util/emilpro/emilpro-9999.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils eutils
+
+DESCRIPTION="a graphical disassembler for a large number of instruction sets"
+HOMEPAGE="http://www.emilpro.com/"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/SimonKagstrom/emilpro"
+ inherit git-r3
+ KEYWORDS=""
+ SRC_URI="mirror://gnu/binutils/binutils-2.23.2.tar.bz2"
+else
+ SRC_URI="http://www.emilpro.com/${P}.tar.gz
+ !system-binutils? ( mirror://gnu/binutils/binutils-2.23.2.tar.bz2 )"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+system-binutils"
+
+DEPEND="|| ( dev-libs/elfutils dev-libs/libelf )
+ dev-cpp/gtkmm:3.0
+ dev-cpp/gtksourceviewmm:3.0
+ dev-cpp/libxmlpp:2.6
+ system-binutils? ( sys-devel/binutils[multitarget] )
+ net-misc/curl"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ if use system-binutils; then
+ epatch "${FILESDIR}"/use-gentoo-binutils.patch
+ else
+ sed -i "s#wget -O binutils.tar.bz2 http://ftp.gnu.org/gnu/binutils/binutils-2.23.2.tar.bz2#cp \"${DISTDIR}/binutils-2.23.2.tar.bz2\" ./binutils.tar.bz2#" cmake/BuildBinutils.cmake
+ fi
+ cmake-utils_src_prepare
+}
+
+src_compile() {
+ if use system-binutils; then
+ cmake-utils_src_compile
+ else
+ #bundled binutils is broken, always builds with one thread
+ #but somehow it still fails if I don't do this
+ cd "${BUILD_DIR}"
+ emake -j1
+ fi
+}
+
+src_install() {
+ dobin "${BUILD_DIR}"/emilpro
+}
diff --git a/dev-util/emilpro/files/respect-cflags.patch b/dev-util/emilpro/files/respect-cflags.patch
new file mode 100644
index 000000000000..12d5bd52db5d
--- /dev/null
+++ b/dev-util/emilpro/files/respect-cflags.patch
@@ -0,0 +1,12 @@
+diff -Naur emilpro-3/CMakeLists.txt emilpro-3-cflags/CMakeLists.txt
+--- emilpro-3/CMakeLists.txt 2013-12-28 04:22:34.000000000 -0500
++++ emilpro-3-cflags/CMakeLists.txt 2014-03-18 17:59:47.534542384 -0400
+@@ -29,7 +29,7 @@
+ pkg_check_modules(LIBXMLPP libxml++-2.6)
+ pkg_check_modules(LIBCURL libcurl)
+
+-set (CMAKE_CXX_FLAGS "-std=c++0x -Wall -D_GLIBCXX_USE_NANOSLEEP -DPACKAGE=emilpro -DPACKAGE_VERSION=1")
++set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++0x -Wall -D_GLIBCXX_USE_NANOSLEEP -DPACKAGE=emilpro -DPACKAGE_VERSION=1")
+ LINK_DIRECTORIES(${CMAKE_BINARY_DIR}/install-binutils/lib ${CMAKE_BINARY_DIR}/install-binutils/lib64)
+
+ if (HAVE_BFD_MULTIARCH)
diff --git a/dev-util/emilpro/files/use-gentoo-binutils.patch b/dev-util/emilpro/files/use-gentoo-binutils.patch
new file mode 100644
index 000000000000..576055810710
--- /dev/null
+++ b/dev-util/emilpro/files/use-gentoo-binutils.patch
@@ -0,0 +1,36 @@
+diff -Naur emilpro-3/CMakeLists.txt emilpro-3-nobinutils/CMakeLists.txt
+--- emilpro-3/CMakeLists.txt 2013-12-28 04:22:34.000000000 -0500
++++ emilpro-3-nobinutils/CMakeLists.txt 2014-03-18 14:59:17.983479920 -0400
+@@ -11,7 +11,6 @@
+ set (BASE_DIR ${CMAKE_CURRENT_SOURCE_DIR})
+
+ # Dependencies
+-include (${CMAKE_CURRENT_SOURCE_DIR}/cmake/BuildBinutils.cmake)
+
+ find_package (LibElf REQUIRED)
+ find_package (PkgConfig REQUIRED)
+@@ -30,7 +29,6 @@
+ pkg_check_modules(LIBCURL libcurl)
+
+ set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++0x -Wall -D_GLIBCXX_USE_NANOSLEEP -DPACKAGE=emilpro -DPACKAGE_VERSION=1")
+-LINK_DIRECTORIES(${CMAKE_BINARY_DIR}/install-binutils/lib ${CMAKE_BINARY_DIR}/install-binutils/lib64)
+
+ if (HAVE_BFD_MULTIARCH)
+ set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -DHAVE_BFD_MULTIARCH")
+@@ -110,7 +108,6 @@
+ src/include/
+ ${CMAKE_BINARY_DIR}
+ ${LIBELF_INCLUDE_DIRS}
+- ${CMAKE_BINARY_DIR}/install-binutils/include/
+ ${GTKMM_INCLUDE_DIRS}
+ ${GTKSOURCEVIEWMM_INCLUDE_DIRS}
+ ${LIBXMLPP_INCLUDE_DIRS}
+@@ -128,8 +125,6 @@
+ tools/squash-instruction-models.cc
+ )
+
+-set_property(TARGET emilpro APPEND PROPERTY OBJECT_DEPENDS binutils)
+-set_property(TARGET tools/squash-instruction-models APPEND PROPERTY OBJECT_DEPENDS binutils)
+
+ set (BASE_LIBS
+ ${LIBELF_LIBRARIES}
diff --git a/dev-util/emilpro/metadata.xml b/dev-util/emilpro/metadata.xml
new file mode 100644
index 000000000000..6151b9b64083
--- /dev/null
+++ b/dev-util/emilpro/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>zerochaos@gentoo.org</email>
+<name>Rick Farina</name>
+</maintainer>
+<longdescription lang="en">
+</longdescription>
+<use>
+<flag name="system-binutils">Use the gentoo binutils instead of building against an unpatched vanilla version</flag>
+</use>
+</pkgmetadata>