summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2018-12-19 23:49:06 +0200
committerMart Raudsepp <leio@gentoo.org>2018-12-19 23:55:46 +0200
commit463be127e688aa3f4ef474d91087644650b7c4c8 (patch)
treed83dba0001d00c1145cd85541de669e38fb83292 /dev-util/gdbus-codegen/gdbus-codegen-2.56.4.ebuild
parentdev-libs/glib: security bump to 2.56.4 (diff)
downloadgentoo-463be127e688aa3f4ef474d91087644650b7c4c8.tar.gz
gentoo-463be127e688aa3f4ef474d91087644650b7c4c8.tar.bz2
gentoo-463be127e688aa3f4ef474d91087644650b7c4c8.zip
dev-util/gdbus-codegen: bump to 2.56.4
Signed-off-by: Mart Raudsepp <leio@gentoo.org> Package-Manager: Portage-2.3.52, Repoman-2.3.11
Diffstat (limited to 'dev-util/gdbus-codegen/gdbus-codegen-2.56.4.ebuild')
-rw-r--r--dev-util/gdbus-codegen/gdbus-codegen-2.56.4.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-util/gdbus-codegen/gdbus-codegen-2.56.4.ebuild b/dev-util/gdbus-codegen/gdbus-codegen-2.56.4.ebuild
new file mode 100644
index 000000000000..64d78265b08d
--- /dev/null
+++ b/dev-util/gdbus-codegen/gdbus-codegen-2.56.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME_ORG_MODULE="glib"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6,3_7} )
+PYTHON_REQ_USE="xml"
+DISTUTILS_SINGLE_IMPL=1
+
+inherit gnome.org distutils-r1
+
+DESCRIPTION="GDBus code and documentation generator"
+HOMEPAGE="https://www.gtk.org/"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE=""
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+
+# To prevent circular dependencies with glib[test]
+PDEPEND=">=dev-libs/glib-${PV}:2"
+
+S="${WORKDIR}/glib-${PV}/gio/gdbus-2.0/codegen"
+
+python_prepare_all() {
+ PATCHES=(
+ "${FILESDIR}/${PN}-2.56.1-sitedir.patch"
+ )
+ distutils-r1_python_prepare_all
+
+ sed -e 's:@PYTHON@:python:' gdbus-codegen.in > gdbus-codegen || die
+ cp "${FILESDIR}/setup.py-2.32.4" setup.py || die "cp failed"
+ sed -e "s/@PV@/${PV}/" -i setup.py || die "sed setup.py failed"
+}
+
+src_test() {
+ einfo "Skipping tests. This package is tested by dev-libs/glib"
+ einfo "when merged with FEATURES=test"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all # no-op, but prevents QA warning
+ doman "${WORKDIR}/glib-${PV}/docs/reference/gio/gdbus-codegen.1"
+}