summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-01-21 16:39:09 +0200
committerMart Raudsepp <leio@gentoo.org>2019-01-21 17:16:05 +0200
commit970d2aa9dc2a64d1b07775674c85332516b51cab (patch)
tree64ff3d0bfde3bc20ad2d946b5a3d41f429976a11 /dev-util/gdbus-codegen
parentdev-util/glib-utils: bump to 2.58.3 (diff)
downloadgentoo-970d2aa9dc2a64d1b07775674c85332516b51cab.tar.gz
gentoo-970d2aa9dc2a64d1b07775674c85332516b51cab.tar.bz2
gentoo-970d2aa9dc2a64d1b07775674c85332516b51cab.zip
dev-util/gdbus-codegen: bump to 2.58.3
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'dev-util/gdbus-codegen')
-rw-r--r--dev-util/gdbus-codegen/Manifest1
-rw-r--r--dev-util/gdbus-codegen/gdbus-codegen-2.58.3.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-util/gdbus-codegen/Manifest b/dev-util/gdbus-codegen/Manifest
index 9cedbcaac1c4..a00178fbbca6 100644
--- a/dev-util/gdbus-codegen/Manifest
+++ b/dev-util/gdbus-codegen/Manifest
@@ -1,2 +1,3 @@
DIST glib-2.56.4.tar.xz 7029768 BLAKE2B 21cf840128e468151eeac55f0323f8f643973422b70bb65655e24c0a6b2f7ee72d5ae879bfae73df84fa2281fc425cc98328597910ba8fd99d7a52024e1b3ab6 SHA512 280a46c2af13283a08c15ff0b4f5492659c2884521930600ad45310ed181c44a878ad8f9b36bae68ed6e7d92db6f1630f7bf015148c513dc317d25807f13abb0
DIST glib-2.58.2.tar.xz 4862612 BLAKE2B e94d3dfc5d4b6d100c2425fda34c90fdf643fdb71b8bd65df691e34d11bfaf79fdc4c844eb215df24b0f680991fb0d0c08c3bb3dea61f5157ccd8bec200e2059 SHA512 4017ae308f2ef6313abbff2eb9b21ec6f8fa38935007491ca0cb4d1ffac6fedab6f50e911ac088995d6212323ba1767399f18529a2620d60378ecade193b4b1a
+DIST glib-2.58.3.tar.xz 4863648 BLAKE2B 4269bd6e80869f39d567917438f750561debb1b45d40ecea487d2e76e2468e07dc8d80a23678699f7b8f7778c2ed9d29e866ae5e33770f51ed00709dd5fe97eb SHA512 1e1cb5b607367dcbadb95563d463e81702cf396b28f1173f6d933707f4f3d5595a70225423e918807a05994a24f16fa3ac87d2ec67e4b670244ea99836634cce
diff --git a/dev-util/gdbus-codegen/gdbus-codegen-2.58.3.ebuild b/dev-util/gdbus-codegen/gdbus-codegen-2.58.3.ebuild
new file mode 100644
index 000000000000..ef933b3fc4f3
--- /dev/null
+++ b/dev-util/gdbus-codegen/gdbus-codegen-2.58.3.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME_ORG_MODULE="glib"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6,3_7} )
+PYTHON_REQ_USE="xml"
+DISTUTILS_SINGLE_IMPL=1
+
+inherit gnome.org distutils-r1
+
+DESCRIPTION="GDBus code and documentation generator"
+HOMEPAGE="https://www.gtk.org/"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE=""
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ app-text/docbook-xsl-stylesheets
+"
+
+# To prevent circular dependencies with glib[test]
+PDEPEND=">=dev-libs/glib-${PV}:2"
+
+S="${WORKDIR}/glib-${PV}/gio/gdbus-2.0/codegen"
+
+python_prepare_all() {
+ PATCHES=(
+ "${FILESDIR}/${PN}-2.56.1-sitedir.patch"
+ )
+ distutils-r1_python_prepare_all
+
+ sed -e 's:@PYTHON@:python:' gdbus-codegen.in > gdbus-codegen || die
+ sed -e "s:@VERSION@:${PV}:" config.py.in > config.py || die
+ cp "${FILESDIR}/setup.py-2.32.4" setup.py || die "cp failed"
+ sed -e "s/@PV@/${PV}/" -i setup.py || die "sed setup.py failed"
+}
+
+do_xsltproc_command() {
+ # Taken from meson.build for manual manpage building - keep in sync (also copied to dev-util/glib-utils)
+ xsltproc \
+ --nonet \
+ --stringparam man.output.quietly 1 \
+ --stringparam funcsynopsis.style ansi \
+ --stringparam man.th.extra1.suppress 1 \
+ --stringparam man.authors.section.enabled 0 \
+ --stringparam man.copyright.section.enabled 0 \
+ -o "${2}" \
+ http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl \
+ "${1}" || die "manpage generation failed"
+}
+
+src_compile() {
+ distutils-r1_src_compile
+ do_xsltproc_command "${WORKDIR}/glib-${PV}/docs/reference/gio/gdbus-codegen.xml" "${WORKDIR}/glib-${PV}/docs/reference/gio/gdbus-codegen.1"
+}
+
+src_test() {
+ einfo "Skipping tests. This package is tested by dev-libs/glib"
+ einfo "when merged with FEATURES=test"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all # no-op, but prevents QA warning
+ doman "${WORKDIR}/glib-${PV}/docs/reference/gio/gdbus-codegen.1"
+}