summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-04-21 21:06:53 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-04-21 21:07:18 -0500
commit42480d1a1ede4295ac45a2b12969d13fb313a4e6 (patch)
tree15dfe0462931ea0ad9286816acc0a2e4b913e8d1 /dev-util/gertty/gertty-9999.ebuild
parentx11-themes/mate-themes: use HTTPS (diff)
downloadgentoo-42480d1a1ede4295ac45a2b12969d13fb313a4e6.tar.gz
gentoo-42480d1a1ede4295ac45a2b12969d13fb313a4e6.tar.bz2
gentoo-42480d1a1ede4295ac45a2b12969d13fb313a4e6.zip
dev-util/gertty: add git master version
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-util/gertty/gertty-9999.ebuild')
-rw-r--r--dev-util/gertty/gertty-9999.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-util/gertty/gertty-9999.ebuild b/dev-util/gertty/gertty-9999.ebuild
new file mode 100644
index 000000000000..c59d3edabcd2
--- /dev/null
+++ b/dev-util/gertty/gertty-9999.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Gertty is a console-based interface to the Gerrit Code Review system."
+HOMEPAGE="https://pypi.org/project/gertty/"
+if [[ ${PV} == *9999 ]];then
+ inherit git-r3
+ EGIT_REPO_URI="https://opendev.org/ttygroup/gertty"
+ EGIT_BRANCH="master"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+SLOT="0"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-0.11[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/urwid-1.2.1[${PYTHON_USEDEP}]
+ !~dev-python/urwid-1.3.0[${PYTHON_USEDEP}]
+ >=dev-python/sqlalchemy-1.0.4[${PYTHON_USEDEP}]
+ >=dev-python/git-python-0.3.7[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.5.3[${PYTHON_USEDEP}]
+ <dev-python/requests-3.0.0[${PYTHON_USEDEP}]
+ dev-python/ordereddict[${PYTHON_USEDEP}]
+ >=dev-python/alembic-0.6.4[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.1.0[${PYTHON_USEDEP}]
+ >=dev-python/voluptuous-0.7[${PYTHON_USEDEP}]
+ >=dev-python/ply-3.4[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"