summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2022-05-11 11:44:06 -0500
committerWilliam Hubbs <williamh@gentoo.org>2022-05-11 11:44:38 -0500
commit3a8e19cb7a45c6e58e80441a1c63d4245e77d8f3 (patch)
tree3a24f344d9dbbfd7763b96712fe29ea347c4c12f /dev-util/gitlab-runner
parentdev-util/gitlab-runner: add 14.10.1 (diff)
downloadgentoo-3a8e19cb7a45c6e58e80441a1c63d4245e77d8f3.tar.gz
gentoo-3a8e19cb7a45c6e58e80441a1c63d4245e77d8f3.tar.bz2
gentoo-3a8e19cb7a45c6e58e80441a1c63d4245e77d8f3.zip
dev-util/gitlab-runner: add 14.9.2
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-util/gitlab-runner')
-rw-r--r--dev-util/gitlab-runner/Manifest2
-rw-r--r--dev-util/gitlab-runner/gitlab-runner-14.9.2.ebuild60
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-util/gitlab-runner/Manifest b/dev-util/gitlab-runner/Manifest
index c4238504e369..28c5788d80f8 100644
--- a/dev-util/gitlab-runner/Manifest
+++ b/dev-util/gitlab-runner/Manifest
@@ -4,3 +4,5 @@ DIST gitlab-runner-14.10.1-deps.tar.xz 142897024 BLAKE2B 353b209e62b87edd7f684c2
DIST gitlab-runner-14.10.1.tar.gz 1265690 BLAKE2B c455c08f1530b4fa6d63d74736adeb7cfb76c5f4f56577e2c22ba64630c88a3b0933fd0e3fbcf173d7263f6150bd77491fa091c5c8a4821dabf4bfee24928a52 SHA512 5b3a6b1b13569a9f24206f078bd864689fc6cf9c7f249b3fc5adb36e9c59bc6b53f218a7e31aab8537f188500f072a8e73ad9422e03e2eb44c21521c903044a1
DIST gitlab-runner-14.9.1-deps.tar.xz 142907928 BLAKE2B fb61c7b03d3dd63196bb4de0042a3c65035a3fc132435d7844635bb968a6bfe43e05fca053bfa96ba22cc9fd601d533857bffdf8bd734e90e86fefce8091da34 SHA512 d077cc1220ad33196655e578937c910c7b368eef57bb96d385eac0957e5f8902bb3720b1614f3179753929f25589a8d1d543bcb61d4cf5972bf4ada96a4056d8
DIST gitlab-runner-14.9.1.tar.gz 1259997 BLAKE2B a4694198630fb2cc47ad4e9fe36b366ae695d8a4618e755b9ff12b608d5d8266614cc649b0e63bca125919ebe8dd40859fc7804cd8bb40ed391a54d6ae65a325 SHA512 ec804f3a4982414d52a4f3b5ff1560c5342a3650f1bb3edefa211a3810b17e202263abc67bfcd4423fe88b5acd501da1d23f3980a078800ab25932625ff75bc5
+DIST gitlab-runner-14.9.2-deps.tar.xz 142907928 BLAKE2B fb61c7b03d3dd63196bb4de0042a3c65035a3fc132435d7844635bb968a6bfe43e05fca053bfa96ba22cc9fd601d533857bffdf8bd734e90e86fefce8091da34 SHA512 d077cc1220ad33196655e578937c910c7b368eef57bb96d385eac0957e5f8902bb3720b1614f3179753929f25589a8d1d543bcb61d4cf5972bf4ada96a4056d8
+DIST gitlab-runner-14.9.2.tar.gz 1260233 BLAKE2B 9632c01ce05375ccec038392c978eedb66287e48263347b73194d4cadab122822bdf6c1b5cdec324501c636e4fe68e65623aeae42b1d8bb34f38281142367da1 SHA512 2f3e5c729bd443fd4943c6521762155fd7b7848d3a64634947be5e8b8e31dd19765502d5abb604b872e1e1fc1fa35e05d49075122f7edeed82760ae53970de32
diff --git a/dev-util/gitlab-runner/gitlab-runner-14.9.2.ebuild b/dev-util/gitlab-runner/gitlab-runner-14.9.2.ebuild
new file mode 100644
index 000000000000..1ad7cc8d7ccd
--- /dev/null
+++ b/dev-util/gitlab-runner/gitlab-runner-14.9.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module systemd tmpfiles
+GIT_COMMIT=bd40e3da
+
+DESCRIPTION="The official GitLab Runner, written in Go"
+HOMEPAGE="https://gitlab.com/gitlab-org/gitlab-runner"
+SRC_URI="https://gitlab.com/gitlab-org/gitlab-runner/-/archive/v${PV}/${PN}-v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+COMMON_DEPEND="acct-group/gitlab-runner
+ acct-user/gitlab-runner"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+BDEPEND="dev-go/gox"
+
+DOCS=( docs CHANGELOG.md README.md config.toml.example )
+
+S="${WORKDIR}/${PN}-v${PV}"
+
+src_compile() {
+ emake \
+ BUILT="$(date -u '+%Y-%m-%dT%H:%M:%S%:z')" \
+ GOX="${EPREFIX}/usr/bin/gox" \
+ REVISION=${GIT_COMMIT} \
+ VERSION=${PV} \
+ runner-bin-host
+}
+
+src_test() {
+ CI=0 ego test
+}
+
+src_install() {
+ dobin out/binaries/gitlab-runner
+ einstalldocs
+
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ newtmpfiles "${FILESDIR}"/${PN}.tmpfile ${PN}.conf
+ keepdir /{etc,var/log}/${PN}
+ fowners gitlab-runner:gitlab-runner /{etc,var/log}/${PN}
+ fperms 0700 /{etc,var/log}/gitlab-runner
+}
+
+pkg_postinst() {
+ tmpfiles_process gitlab-runner.conf
+ [[ -f ${EROOT}/etc/gitlab-runner/config.toml ]] && return
+ elog
+ elog "To use the runner, you need to register it with this command:"
+ elog "# gitlab-runner register"
+ elog "This will also create the configuration file in /etc/gitlab-runner/config.toml"
+}