summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-06-25 12:31:00 +0200
committerPacho Ramos <pacho@gentoo.org>2016-06-25 14:20:22 +0200
commit308177cd5f648ffcda2cfc6acc9b3ec88705d817 (patch)
tree3624d9d922c8e4bb292174058c62d4162d2930bd /dev-util/glade
parentdev-libs/glib: Handle debug (diff)
downloadgentoo-308177cd5f648ffcda2cfc6acc9b3ec88705d817.tar.gz
gentoo-308177cd5f648ffcda2cfc6acc9b3ec88705d817.tar.bz2
gentoo-308177cd5f648ffcda2cfc6acc9b3ec88705d817.zip
dev-util/glade: Version bump
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'dev-util/glade')
-rw-r--r--dev-util/glade/Manifest1
-rw-r--r--dev-util/glade/glade-3.20.0.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/dev-util/glade/Manifest b/dev-util/glade/Manifest
index 9f18ac1f85b7..1c2dd097c52f 100644
--- a/dev-util/glade/Manifest
+++ b/dev-util/glade/Manifest
@@ -1,2 +1,3 @@
DIST glade-3.18.3.tar.xz 3266400 SHA256 ecdbce46e7fbfecd463be840b94fbf54d83723b3ebe075414cfd225ddab66452 SHA512 6e98d6ba98118fde4066f983024818528ac8c82d176896e2c5c62a19094377df4bf4c6b4edd028cd72bf8744c807c28a930e467f2a23670537b02af327b683f8 WHIRLPOOL 4e1e86b86216739007b3524464a5fcaf07c66ba5adc36a3c497c0c411401fffc6345db2722a1b0f85d1e1e13c920553014e4eac3bdbbd2dcc7ddbd8ac7cb41a3
+DIST glade-3.20.0.tar.xz 3492928 SHA256 82d96dca5dec40ee34e2f41d49c13b4ea50da8f32a3a49ca2da802ff14dc18fe SHA512 58c8da3522c75470f5b42492bddd83f61d828fa2a3fb8a78d15813f6d1f1df22bd808f25ae7228bf2e821bacdcc5665b889bac3ea8364c4dac288f95e817e98a WHIRLPOOL 403bccfa596c306d997df2db115496885db70e04610340e3ceb1ddbd9d2868a1188cf3d164d4ea101442ae8e9cbcc6f2dea351bcc4b59c1bac41f0c315f9a6d8
DIST glade3-3.8.5.tar.xz 2322076 SHA256 58a5f6e4df4028230ddecc74c564808b7ec4471b1925058e29304f778b6b2735 SHA512 722a33f1a1ec3baa785bf3c6f7f5ec2cbe7cf6fe44c9c26d33728de16f2856cbb1ace0cd38c5b5356081e326666cc82fd00f2b6af53bd06bb832079610042985 WHIRLPOOL 672c38822dd04e43e2a3c6642fa34e9e485172d943a0abd5e16f7f378f73bc9126768955d9aad431960f5966be8edaa26a755ca28e2644a790c111e0b6c0142d
diff --git a/dev-util/glade/glade-3.20.0.ebuild b/dev-util/glade/glade-3.20.0.ebuild
new file mode 100644
index 000000000000..3beebf8218c4
--- /dev/null
+++ b/dev-util/glade/glade-3.20.0.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome2 python-single-r1 versionator virtualx
+
+DESCRIPTION="A user interface designer for GTK+ and GNOME"
+HOMEPAGE="https://glade.gnome.org/"
+
+LICENSE="GPL-2+ FDL-1.1+"
+SLOT="3.10/6" # subslot = suffix of libgladeui-2.so
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+
+IUSE="debug +introspection python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ dev-libs/atk[introspection?]
+ >=dev-libs/glib-2.32:2
+ >=dev-libs/libxml2-2.4.0:2
+ x11-libs/cairo:=
+ x11-libs/gdk-pixbuf:2[introspection?]
+ >=x11-libs/gtk+-3.20.0:3[introspection?]
+ x11-libs/pango[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-1.32:= )
+ python? (
+ ${PYTHON_DEPS}
+ >=dev-python/pygobject-3.8:3[${PYTHON_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/yelp-tools
+ dev-libs/libxslt
+ >=dev-util/gtk-doc-am-1.13
+ >=dev-util/intltool-0.41.0
+ dev-util/itstool
+ virtual/pkgconfig
+
+ dev-libs/gobject-introspection-common
+ gnome-base/gnome-common
+"
+# eautoreconf requires:
+# dev-libs/gobject-introspection-common
+# gnome-base/gnome-common
+
+PATCHES=(
+ # To avoid file collison with other slots, rename help module.
+ # Prevent the UI from loading glade:3's gladeui devhelp documentation.
+ "${FILESDIR}"/${PN}-3.14.1-doc-version.patch
+)
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ --enable-gladeui \
+ --enable-libtool-lock \
+ $(usex debug --enable-debug ' ') \
+ $(use_enable introspection) \
+ $(use_enable python)
+}
+
+src_test() {
+ virtx emake check
+}
+
+src_install() {
+ # modify Name in .desktop file to avoid confusion with other slots
+ sed -e 's:^\(Name.*=Glade\):\1 '$(get_version_component_range 1-2): \
+ -i data/glade.desktop || die "sed of data/glade.desktop failed"
+ # modify name in .devhelp2 file to avoid shadowing with glade:3 docs
+ sed -e 's:name="gladeui":name="gladeui-2":' \
+ -i doc/html/gladeui.devhelp2 || die "sed of gladeui.devhelp2 failed"
+ gnome2_src_install
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ if ! has_version dev-util/devhelp ; then
+ elog "You may want to install dev-util/devhelp for integration API"
+ elog "documentation support."
+ fi
+}