summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-03-15 13:42:57 -0700
committerMatt Turner <mattst88@gentoo.org>2020-03-15 14:28:02 -0700
commitc1d34d8955cd9d7327a56cbe8f8ed895215527be (patch)
treeeaa34a608c44e24d7d21c0fb2d90b8902c0640e4 /dev-util/glslang/glslang-9999.ebuild
parentdev-util/spirv-tools: Version bump to 2020.1 (diff)
downloadgentoo-c1d34d8955cd9d7327a56cbe8f8ed895215527be.tar.gz
gentoo-c1d34d8955cd9d7327a56cbe8f8ed895215527be.tar.bz2
gentoo-c1d34d8955cd9d7327a56cbe8f8ed895215527be.zip
dev-util/glslang: 9999 cleanup, cmake.eclass
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-util/glslang/glslang-9999.ebuild')
-rw-r--r--dev-util/glslang/glslang-9999.ebuild21
1 files changed, 12 insertions, 9 deletions
diff --git a/dev-util/glslang/glslang-9999.ebuild b/dev-util/glslang/glslang-9999.ebuild
index bbdb6606eab1..6de396f95da7 100644
--- a/dev-util/glslang/glslang-9999.ebuild
+++ b/dev-util/glslang/glslang-9999.ebuild
@@ -1,23 +1,26 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=(python{3_6,3_7})
+CMAKE_ECLASS="cmake"
+PYTHON_COMPAT=( python3_{6,7} )
+inherit cmake-multilib python-any-r1
-inherit cmake-multilib cmake-utils python-any-r1 git-r3
-
-EGIT_REPO_URI="https://github.com/KhronosGroup/glslang.git"
-SRC_URI=""
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/KhronosGroup/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/KhronosGroup/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~ppc64 ~x86"
+fi
DESCRIPTION="Khronos reference front-end for GLSL and ESSL, and sample SPIR-V generator"
-HOMEPAGE="https://www.khronos.org/opengles/sdk/tools/Reference-Compiler/"
+HOMEPAGE="https://www.khronos.org/opengles/sdk/tools/Reference-Compiler/ https://github.com/KhronosGroup/glslang"
LICENSE="BSD"
SLOT="0"
-PATCHES=( "${FILESDIR}/${P}-fix-relative-includes.patch" )
-
RDEPEND="!<media-libs/shaderc-2019-r1"
BDEPEND="${PYTHON_DEPS}"