summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2017-08-29 00:04:55 +0200
committerSebastian Pipping <sping@gentoo.org>2017-08-29 00:12:13 +0200
commit03be8ce1d8f96b5ac88262b9b3d989fdf32b0959 (patch)
tree9a97031f7967393e3b3af3cdd00777749890ea08 /dev-util/gprof2dot/gprof2dot-2013.05.17.ebuild
parentx11-libs/gdk-pixbuf: security version bump 2.36.6 → 2.36.9, bug #611390 (diff)
downloadgentoo-03be8ce1d8f96b5ac88262b9b3d989fdf32b0959.tar.gz
gentoo-03be8ce1d8f96b5ac88262b9b3d989fdf32b0959.tar.bz2
gentoo-03be8ce1d8f96b5ac88262b9b3d989fdf32b0959.zip
dev-util/gprof2dot: 2016.10.13
.. with distutils-r1 and EAPI 6. Also fix license, and re-version 0_p20130517 as 2013.05.17. Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-util/gprof2dot/gprof2dot-2013.05.17.ebuild')
-rw-r--r--dev-util/gprof2dot/gprof2dot-2013.05.17.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-util/gprof2dot/gprof2dot-2013.05.17.ebuild b/dev-util/gprof2dot/gprof2dot-2013.05.17.ebuild
new file mode 100644
index 000000000000..8edb2a36308e
--- /dev/null
+++ b/dev-util/gprof2dot/gprof2dot-2013.05.17.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+PYTHON_REQ_USE='xml'
+
+inherit eutils python-r1
+
+MY_PV=0_p${PV//./}
+MY_P=${PN}-${MY_PV}
+DESCRIPTION="Converts profiling output to dot graphs"
+HOMEPAGE="https://github.com/jrfonseca/gprof2dot"
+SRC_URI="http://www.hartwork.org/public/${MY_P}.tar.xz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${MY_P}-py3-xrange.patch
+}
+
+_make_call_script() {
+ cat <<-EOF >"${ED}/$1"
+ #! /usr/bin/env python
+ from gprof2dot import Main
+ Main().main()
+ EOF
+
+ fperms a+x "$1" || die
+}
+
+src_install() {
+ abi_specific_install() {
+ local sitedir="$(python_get_sitedir)"
+ insinto ${sitedir#"${EPREFIX}"}
+ doins ${PN}.py || die
+ python_optimize || die
+ }
+ python_foreach_impl abi_specific_install
+
+ dodir /usr/bin || die
+ _make_call_script /usr/bin/${PN} || die
+ python_replicate_script "${ED}"/usr/bin/${PN} || die
+}