summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2023-04-20 19:31:52 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2023-04-20 21:29:22 +0300
commit1ec6c64d08ae05fc322079882a764c7c52476ee3 (patch)
tree352fd8dab1d92f39c7d3805439f5259a3a4bb05b /dev-util/huc
parentdev-util/huc: use HTTPS, fix LICENSE (diff)
downloadgentoo-1ec6c64d08ae05fc322079882a764c7c52476ee3.tar.gz
gentoo-1ec6c64d08ae05fc322079882a764c7c52476ee3.tar.bz2
gentoo-1ec6c64d08ae05fc322079882a764c7c52476ee3.zip
dev-util/huc: EAPI8 bump
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/30669 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-util/huc')
-rw-r--r--dev-util/huc/huc-0.1-r2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-util/huc/huc-0.1-r2.ebuild b/dev-util/huc/huc-0.1-r2.ebuild
new file mode 100644
index 000000000000..50a2ea0f13bd
--- /dev/null
+++ b/dev-util/huc/huc-0.1-r2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="HTML umlaut conversion tool"
+SRC_URI="https://www.int21.de/huc/${P}.tar.bz2"
+HOMEPAGE="https://www.int21.de/huc"
+
+SLOT="0"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-linux ~ppc-macos"
+
+src_compile() {
+ $(tc-getCXX) \
+ ${LDFLAGS} ${CXXFLAGS} \
+ -o ${PN} ${PN}.cpp || die "compile failed"
+}
+
+src_install() {
+ dobin "${PN}"
+ einstalldocs
+}