summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-03-13 19:15:00 +0100
committerPatrice Clement <monsieurp@gentoo.org>2017-03-14 00:00:21 +0100
commit554c8cbb1c69368da289ce8a95f4d83f064390cc (patch)
tree0f7d2f93d95df20c06f0caaa6ac1ca5695e8e671 /dev-util/hxd/hxd-0.70.02-r2.ebuild
parentapp-text/mandoc: use mman.conf to avoid man.conf collsion #607506 (diff)
downloadgentoo-554c8cbb1c69368da289ce8a95f4d83f064390cc.tar.gz
gentoo-554c8cbb1c69368da289ce8a95f4d83f064390cc.tar.bz2
gentoo-554c8cbb1c69368da289ce8a95f4d83f064390cc.zip
dev-util/hxd: EAPI 6 bump.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-util/hxd/hxd-0.70.02-r2.ebuild')
-rw-r--r--dev-util/hxd/hxd-0.70.02-r2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-util/hxd/hxd-0.70.02-r2.ebuild b/dev-util/hxd/hxd-0.70.02-r2.ebuild
new file mode 100644
index 000000000000..ad8dc60558e7
--- /dev/null
+++ b/dev-util/hxd/hxd-0.70.02-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Binary to hexadecimal converter"
+HOMEPAGE="http://www-tet.ee.tu-berlin.de/solyga/linux/"
+SRC_URI="http://linux.xulin.de/c/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~sparc ~mips ~ppc"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-prll-flags.patch
+ "${FILESDIR}"/${P}-llong-redef.patch
+)
+
+DOCS=( README TODO )
+
+src_prepare() {
+ default
+ tc-export CC
+}
+
+src_install() {
+ dobin "${PN}" "un${PN}"
+ doman "${PN}.1" "un${PN}.1"
+ einstalldocs
+}