summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2021-04-29 15:19:25 -0400
committerMike Pagano <mpagano@gentoo.org>2021-04-29 15:19:25 -0400
commit447086095d836e6f2f93c8eb26000a659c9f76eb (patch)
tree3a9c8e51604075209b965cef76f7c6a78c35adeb /dev-util/idea-community
parentsys-libs/db: stable 5.3.28-r7 for hppa, bug #736870 (diff)
downloadgentoo-447086095d836e6f2f93c8eb26000a659c9f76eb.tar.gz
gentoo-447086095d836e6f2f93c8eb26000a659c9f76eb.tar.bz2
gentoo-447086095d836e6f2f93c8eb26000a659c9f76eb.zip
dev-util/idea-community: Version bump, drop old
Drop 2021*.3.1.203.6682.168-r3 Add 2021.3.1.211.6693.111 Thanks to Martin Eberle for reporting. Closes: https://bugs.gentoo.org/786477 Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'dev-util/idea-community')
-rw-r--r--dev-util/idea-community/Manifest2
-rw-r--r--dev-util/idea-community/files/idea-community-jdk.patch10
-rw-r--r--dev-util/idea-community/idea-community-2021.3.1.211.6693.111.ebuild138
3 files changed, 145 insertions, 5 deletions
diff --git a/dev-util/idea-community/Manifest b/dev-util/idea-community/Manifest
index efa611895f90..f06e3e3bf003 100644
--- a/dev-util/idea-community/Manifest
+++ b/dev-util/idea-community/Manifest
@@ -1,2 +1,4 @@
DIST ideaIC-3.1.203.6682.168.tar.gz 577542631 BLAKE2B d47d017b76fa9106a55805b558bd49d6d45dd216ac28151f03cc2a7f3a751707b62fa49623bb04b426d90cfd1cce4e04b2490bb91ec01dfeccdf4a80f1694f7e SHA512 71849f9440c34359a23af1f4735c3b0ac6378f6ab8ddf5799ad7e26036dc87b4abbc234043bd368a7698daf91f83cf989539054db7e1fb9ea95ebf7d756ac068
+DIST ideaIC-3.1.211.6693.111.tar.gz 652142239 BLAKE2B 7ce39420fd42c829ce1e742be20f37a255c3452740e77ee276495932dcab2db50aad1ce43a27aff6d02821a5e9d9c69d782c6a35ce7621d6b2abf14e29c45808 SHA512 cb7e8bf31f7ce87ab29483086ed3cbb5bd2a638c9179f9131de0344d97947950abecd5aec1d98e881434bb2f72aafd440cafc358829db3516d0e960eae722da0
+DIST jbr-11_0_10-linux-x64-b1304.4.tar.gz 201507596 BLAKE2B aa83f396dd37a96c769806c3f95a4c78bcc31e9c8eda047903cbee932a84029ad7133fc03496a248c017795ec45ff42f30f3860780a00d9d766ac7b262019905 SHA512 0de75baac30dad42927fa0cef3b78dc183f4dd317f8426021dd51cf1288680bbc65ed934e867dfa3ca9397d9bd5cff4b4d6896eb4878323c8b0aaa2b39d33d82
DIST jbr-11_0_8-linux-x64-b1098.1.tar.gz 191689225 BLAKE2B 0da0f0e834709c89820f2e7e1c447dc33ea1c59c7dfb573aa47bc205f7920ccf485454f79931d42d4e6eb4de1017589bb908808d6a80cc586659757abc9958d3 SHA512 a455d8bd3332622592186cd7ae3995a9148a47717a81c274497f5408f1e89ef637c7478321b4ccd5dbe97c2e246a16ac8956c5ce475f8a4156232647f0ea7737
diff --git a/dev-util/idea-community/files/idea-community-jdk.patch b/dev-util/idea-community/files/idea-community-jdk.patch
index b89e6773fd01..5556729fdd49 100644
--- a/dev-util/idea-community/files/idea-community-jdk.patch
+++ b/dev-util/idea-community/files/idea-community-jdk.patch
@@ -1,11 +1,11 @@
---- a/bin/idea.sh 2020-12-30 15:51:43.743936660 -0500
-+++ b/bin/idea.sh 2020-12-30 17:58:16.759719538 -0500
-@@ -66,6 +66,8 @@ PATHS_SELECTOR="IdeaIC2020.3"
+--- a/bin/idea.sh 2021-04-29 14:52:57.173162184 -0400
++++ b/bin/idea.sh 2021-04-29 14:54:40.733748978 -0400
+@@ -52,6 +52,8 @@ PATHS_SELECTOR="IdeaIC2021.1"
# shellcheck disable=SC2154
if [ -n "$IDEA_JDK" ] && [ -x "$IDEA_JDK/bin/java" ]; then
- JDK="$IDEA_JDK"
+ JRE="$IDEA_JDK"
+else
+ JDK="/opt/openjdk-bin-11" && [[ -d "/opt/openjdk-11" ]] && JDK="/usr/lib64/openjdk-bin-11"
fi
- if [ -z "$JDK" ] && [ -s "${XDG_CONFIG_HOME:-$HOME/.config}/${PRODUCT_VENDOR}/${PATHS_SELECTOR}/idea.jdk" ]; then
+ BITS=""
diff --git a/dev-util/idea-community/idea-community-2021.3.1.211.6693.111.ebuild b/dev-util/idea-community/idea-community-2021.3.1.211.6693.111.ebuild
new file mode 100644
index 000000000000..35a6a1bcf8ed
--- /dev/null
+++ b/dev-util/idea-community/idea-community-2021.3.1.211.6693.111.ebuild
@@ -0,0 +1,138 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit eutils desktop
+
+SLOT="0"
+PV_STRING="$(ver_cut 2-6)"
+MY_PV="$(ver_cut 1-1).$(ver_cut 3-3)"
+MY_PN="idea"
+# Using the most recent Jetbrains Runtime binaries available at the time of writing
+# ( jre 11.0.10 build 1304.4 )
+JRE11_BASE="11_0_10"
+JRE11_VER="1304.4"
+IDEA_VER="2.111705284.1737970125.1619718960-2104634719.1619551776"
+
+# distinguish settings for official stable releases and EAP-version releases
+if [[ "$(ver_cut 7)"x = "prex" ]]
+then
+ # upstream EAP
+ SRC_URI="https://download.jetbrains.com/idea/${MY_PN}IC-${MY_PV}.tar.gz?_ga=${IDEA_VER}"
+else
+ # upstream stable
+ KEYWORDS="~amd64 ~arm64"
+ SRC_URI="https://download.jetbrains.com/idea/${MY_PN}IC-${MY_PV}-no-jbr.tar.gz?_ga=${IDEA_VER} -> ${MY_PN}IC-${PV_STRING}.tar.gz
+ amd64? ( https://bintray.com/jetbrains/intellij-jbr/download_file?file_path=jbr-${JRE11_BASE}-linux-x64-b${JRE11_VER}.tar.gz -> jbr-${JRE11_BASE}-linux-x64-b${JRE11_VER}.tar.gz )"
+fi
+
+DESCRIPTION="A complete toolset for web, mobile and enterprise development"
+HOMEPAGE="https://www.jetbrains.com/idea"
+
+LICENSE="Apache-2.0 BSD BSD-2 CC0-1.0 CC-BY-2.5 CDDL-1.1
+ codehaus-classworlds CPL-1.0 EPL-1.0 EPL-2.0
+ GPL-2 GPL-2-with-classpath-exception ISC
+ JDOM LGPL-2.1 LGPL-2.1+ LGPL-3-with-linking-exception MIT
+ MPL-1.0 MPL-1.1 OFL ZLIB"
+
+DEPEND="
+ || (
+ >=dev-java/openjdk-11.0.11_p9-r1:11
+ >=dev-java/openjdk-bin-11.0.11_p9-r1:11
+ )"
+RDEPEND="${DEPEND}
+ dev-java/jansi-native
+ dev-libs/libdbusmenu
+ media-libs/harfbuzz
+ =dev-util/lldb-10*"
+
+BDEPEND="dev-util/patchelf"
+RESTRICT="splitdebug"
+S="${WORKDIR}/${MY_PN}-IC-$(ver_cut 4-6)"
+
+QA_PREBUILT="opt/${PN}-${MY_PV}/*"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-jdk.patch"
+)
+
+src_unpack() {
+ default_src_unpack
+ mkdir jre64 && cd jre64 && unpack jbr-${JRE11_BASE}-linux-x64-b${JRE11_VER}.tar.gz
+}
+
+src_prepare() {
+
+ default_src_prepare
+
+ if use amd64; then
+ JRE_DIR=jre64
+ else
+ JRE_DIR=jre
+ fi
+
+ PLUGIN_DIR="${S}/${JRE_DIR}/lib/"
+
+ rm -vf ${PLUGIN_DIR}/libavplugin*
+ rm -vf "${S}"/plugins/maven/lib/maven3/lib/jansi-native/*/libjansi*
+ rm -vrf "${S}"/lib/pty4j-native/linux/ppc64le
+ rm -vf "${S}"/bin/libdbm64*
+ rm -vf "${S}"/lib/pty4j-native/linux/mips64el/libpty.so
+
+ if [[ -d "${S}"/"${JRE_DIR}" ]]; then
+ for file in "${PLUGIN_DIR}"/{libfxplugins.so,libjfxmedia.so}
+ do
+ if [[ -f "$file" ]]; then
+ patchelf --set-rpath '$ORIGIN' $file || die
+ fi
+ done
+ fi
+
+ patchelf --replace-needed liblldb.so liblldb.so.10 "${S}"/plugins/Kotlin/bin/linux/LLDBFrontend || die "Unable to patch LLDBFrontend for lldb"
+ if use arm64; then
+ patchelf --replace-needed libc.so libc.so.6 "${S}"/lib/pty4j-native/linux/aarch64/libpty.so || die "Unable to patch libpty for libc"
+ else
+ rm -vf "${S}"/lib/pty4j-native/linux/aarch64/libpty.so
+ fi
+
+ sed -i \
+ -e "\$a\\\\" \
+ -e "\$a#-----------------------------------------------------------------------" \
+ -e "\$a# Disable automatic updates as these are handled through Gentoo's" \
+ -e "\$a# package manager. See bug #704494" \
+ -e "\$a#-----------------------------------------------------------------------" \
+ -e "\$aide.no.platform.update=Gentoo" bin/idea.properties
+
+ eapply_user
+}
+
+src_install() {
+ local dir="/opt/${PN}-${MY_PV}"
+
+ insinto "${dir}"
+ doins -r *
+ fperms 755 "${dir}"/bin/{format.sh,idea.sh,inspect.sh,printenv.py,restart.py,fsnotifier{,64}}
+ if use amd64; then
+ JRE_DIR=jre64
+ else
+ JRE_DIR=jre
+ fi
+
+ JRE_BINARIES="jaotc java javapackager jjs jrunscript keytool pack200 rmid rmiregistry unpack200"
+ if [[ -d ${JRE_DIR} ]]; then
+ for jrebin in $JRE_BINARIES; do
+ fperms 755 "${dir}"/"${JRE_DIR}"/bin/"${jrebin}"
+ done
+ fi
+
+ make_wrapper "${PN}" "${dir}/bin/${MY_PN}.sh"
+ newicon "bin/${MY_PN}.png" "${PN}.png"
+ make_desktop_entry "${PN}" "IntelliJ Idea Community" "${PN}" "Development;IDE;"
+
+ # recommended by: https://confluence.jetbrains.com/display/IDEADEV/Inotify+Watches+Limit
+ mkdir -p "${D}/etc/sysctl.d/" || die
+ echo "fs.inotify.max_user_watches = 524288" > "${D}/etc/sysctl.d/30-idea-inotify-watches.conf" || die
+
+ # remove bundled harfbuzz
+ rm -f "${D}"/lib/libharfbuzz.so || die
+}