summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-01-25 22:12:11 +0000
committerMarek Szuba <marecki@gentoo.org>2020-01-25 22:12:36 +0000
commitb2f5066108477cba847e8c0ef7b1fd0d59d796ad (patch)
tree93e624d53c27594f50da0c6580f76cb807f23fce /dev-util/intel-graphics-compiler
parentdev-vcs/hg-evolve: Add support for Python 3.6 (diff)
downloadgentoo-b2f5066108477cba847e8c0ef7b1fd0d59d796ad.tar.gz
gentoo-b2f5066108477cba847e8c0ef7b1fd0d59d796ad.tar.bz2
gentoo-b2f5066108477cba847e8c0ef7b1fd0d59d796ad.zip
dev-util/intel-graphics-compiler: bump to 1.0.3151
It still depends on llvm-8 though, it gave me a lot of "undefined reference" errors when I tried to build it against 9.0.1. Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-util/intel-graphics-compiler')
-rw-r--r--dev-util/intel-graphics-compiler/Manifest1
-rw-r--r--dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.3151.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-util/intel-graphics-compiler/Manifest b/dev-util/intel-graphics-compiler/Manifest
index 78b013a4f64a..cc17dcf05fce 100644
--- a/dev-util/intel-graphics-compiler/Manifest
+++ b/dev-util/intel-graphics-compiler/Manifest
@@ -1,2 +1,3 @@
DIST intel-graphics-compiler-1.0.2878.tar.gz 5920418 BLAKE2B 99522118d08183836c6e62f80c98b2cc716dd22d7dc82d05841e87e42f10025508c6254cebe2f886da8454cc4cc4b3a9ee06ce5a3bc04246c88f499f63f8f1ae SHA512 3b6dc9b945fddb3d0bc716f4598c4dacb6431c342b580c90f7e9ff8682bdcbde410a960adbfd9e67601d121adc70d2cf23de01bc99c1d0cb86d14b4db77afde5
DIST intel-graphics-compiler-1.0.2990.tar.gz 5930890 BLAKE2B 038761e74dde52de53eed511a74a39d9b4c69a510ef289d2941b859aea018d6776b5179d2be006b12d3245ffe43a06bfacd9d03ee2d227c2ba2ea39805bf40d2 SHA512 65287348e98f09096418afa02262ad6ce07dd918aa040ac1fb49f7176545c0a6449e68c5e74a11c41641d90495edc7be8e24b32e68d798df906ea3b16e675827
+DIST intel-graphics-compiler-1.0.3151.tar.gz 5950502 BLAKE2B 8ccbfc5d3cd6307eb5db602822d42e8744e6ca7696494a0dd349847aff0defde2434b9192f17645f1fcbf732ec98a66dbdcc7d03eed48702d90911f912135fc1 SHA512 a6e04a3a90aae9046f2698bf15d5f60862c93e7a87a6e4ae6b6c43c65490583608f201e94a2ef32fc2f72e9fa0da7d6c202f64ef610f03a81384ac537541df14
diff --git a/dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.3151.ebuild b/dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.3151.ebuild
new file mode 100644
index 000000000000..524909557766
--- /dev/null
+++ b/dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.3151.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-multilib llvm
+
+DESCRIPTION="LLVM-based OpenCL compiler targetting Intel Gen graphics hardware"
+HOMEPAGE="https://github.com/intel/intel-graphics-compiler"
+SRC_URI="https://github.com/intel/${PN}/archive/igc-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+COMMON="sys-devel/llvm:8=[${MULTILIB_USEDEP}]
+ dev-libs/opencl-clang:8=[${MULTILIB_USEDEP}]"
+DEPEND="${COMMON}"
+RDEPEND="${COMMON}"
+
+LLVM_MAX_SLOT=8
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.9-no_Werror.patch
+)
+
+S="${WORKDIR}"/${PN}-igc-${PV}
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_LIBRARY_PATH=$(get_llvm_prefix ${LLVM_MAX_SLOT})/$(get_libdir)
+ -DIGC_OPTION__FORCE_SYSTEM_LLVM=ON
+ -DIGC_PREFERRED_LLVM_VERSION=${LLVM_MAX_SLOT}
+ )
+ cmake-utils_src_configure
+}