summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-08-28 14:10:21 +0200
committerConrad Kostecki <conikost@gentoo.org>2021-08-28 14:25:17 +0200
commitb37cf38b6051bd3148a7de55981ec84afd096ccb (patch)
tree41e0581d8039a8298bc0c7491188239ae792c3bb /dev-util/intel-graphics-compiler
parentsys-apps/ipmicfg: drop old version (diff)
downloadgentoo-b37cf38b6051bd3148a7de55981ec84afd096ccb.tar.gz
gentoo-b37cf38b6051bd3148a7de55981ec84afd096ccb.tar.bz2
gentoo-b37cf38b6051bd3148a7de55981ec84afd096ccb.zip
dev-util/intel-graphics-compiler: fix python handling
Closes: https://bugs.gentoo.org/810754 Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-util/intel-graphics-compiler')
-rw-r--r--dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.8365-r1.ebuild16
1 files changed, 12 insertions, 4 deletions
diff --git a/dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.8365-r1.ebuild b/dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.8365-r1.ebuild
index c883ba1d6b6a..5f73442c79b4 100644
--- a/dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.8365-r1.ebuild
+++ b/dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.8365-r1.ebuild
@@ -7,8 +7,9 @@ CMAKE_BUILD_TYPE="Release"
LLVM_MAX_SLOT="10"
MY_PN="igc"
MY_P="${MY_PN}-${PV}"
+PYTHON_COMPAT=( python3_{8..10} )
-inherit cmake flag-o-matic llvm
+inherit cmake flag-o-matic llvm python-any-r1
DESCRIPTION="LLVM-based OpenCL compiler for OpenCL targetting Intel Gen graphics hardware"
HOMEPAGE="https://github.com/intel/intel-graphics-compiler"
@@ -27,7 +28,10 @@ DEPEND="
RDEPEND="${DEPEND}"
-BDEPEND=">=sys-devel/lld-${LLVM_MAX_SLOT}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ >=sys-devel/lld-${LLVM_MAX_SLOT}
+"
PATCHES=(
"${FILESDIR}/${PN}-1.0.9-no_Werror.patch"
@@ -38,6 +42,11 @@ PATCHES=(
"${FILESDIR}/${PN}-1.0.8365-cmake-minimum-version.patch"
)
+pkg_setup() {
+ llvm_pkg_setup
+ python-any-r1_pkg_setup
+}
+
src_configure() {
# Since late March 2020 cmake.eclass does not set -DNDEBUG any more,
# and the way IGC uses this definition causes problems for some users.
@@ -52,10 +61,9 @@ src_configure() {
-DIGC_OPTION__ARCHITECTURE_TARGET="Linux64"
-DIGC_OPTION__CLANG_MODE="Prebuilds"
-DIGC_OPTION__LLD_MODE="Prebuilds"
+ -DIGC_OPTION__LLDELF_H_DIR="${EPREFIX}/usr/include/lld/Common"
-DIGC_OPTION__LLVM_MODE="Prebuilds"
-DIGC_OPTION__LLVM_PREFERRED_VERSION="${LLVM_MAX_SLOT}"
- -DIGC_OPTION__SPIRV_TRANSLATOR_MODE="Prebuilds"
- -DIGC_OPTION__USE_KHRONOS_SPIRV_TRANSLATOR_IN_VC="ON"
# VectorCompiler needs work, as at the moment upstream
# only supports building vc-intrinsics in place.