summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/intel-ocl-sdk/intel-ocl-sdk-2.0.31360.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/intel-ocl-sdk/intel-ocl-sdk-2.0.31360.ebuild')
-rw-r--r--dev-util/intel-ocl-sdk/intel-ocl-sdk-2.0.31360.ebuild71
1 files changed, 71 insertions, 0 deletions
diff --git a/dev-util/intel-ocl-sdk/intel-ocl-sdk-2.0.31360.ebuild b/dev-util/intel-ocl-sdk/intel-ocl-sdk-2.0.31360.ebuild
new file mode 100644
index 000000000000..acfed9be595e
--- /dev/null
+++ b/dev-util/intel-ocl-sdk/intel-ocl-sdk-2.0.31360.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+MY_P=${PN//-/_}_2012_x64
+
+inherit rpm multilib
+
+INTEL_CL=usr/$(get_libdir)/OpenCL/vendors/intel/
+
+DESCRIPTION="Intel's implementation of the OpenCL standard optimized for Intel processors"
+HOMEPAGE="http://software.intel.com/en-us/articles/opencl-sdk/"
+SRC_URI="http://registrationcenter.intel.com/irc_nas/2563/intel_sdk_for_ocl_applications_2012_x64.tgz"
+
+LICENSE="Intel-SDP"
+SLOT="0"
+IUSE="tools"
+KEYWORDS="amd64 -x86"
+
+RDEPEND="app-eselect/eselect-opencl
+ dev-cpp/tbb
+ sys-process/numactl
+ tools? (
+ sys-devel/llvm
+ >=virtual/jre-1.6
+ )"
+DEPEND=""
+
+RESTRICT="mirror"
+QA_EXECSTACK="${INTEL_CL/\//}libcpu_device.so
+ ${INTEL_CL/\//}libOclCpuBackEnd.so
+ ${INTEL_CL/\//}libtask_executor.so"
+QA_PREBUILT="${INTEL_CL}*"
+
+S=${WORKDIR}
+
+src_unpack() {
+ default
+ rpm_unpack ./${MY_P}.rpm
+}
+
+src_prepare() {
+ # Remove unnecessary and bundled stuff
+ rm -rf ${INTEL_CL}/{docs,version.txt,llc}
+ rm -f ${INTEL_CL}/libboost*.so
+ rm -f ${INTEL_CL}/libtbb*
+ if ! use tools; then
+ rm -rf usr/bin
+ rm -f ${INTEL_CL}/{ioc64,ioc.jar}
+ rm -f ${INTEL_CL}/libboost*
+ fi
+}
+
+src_install() {
+ doins -r etc
+
+ insinto ${INTEL_CL}
+ doins -r usr/include
+
+ insopts -m 755
+ newins usr/$(get_libdir)/libOpenCL.so libOpenCL.so.1
+ dosym libOpenCL.so.1 ${INTEL_CL}/libOpenCL.so
+
+ doins ${INTEL_CL}/*
+}
+
+pkg_postinst() {
+ eselect opencl set --use-old intel
+}