summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-11-17 16:17:11 +0200
committerMart Raudsepp <leio@gentoo.org>2019-11-17 16:17:26 +0200
commit6efd678c2d2720c172a538521d566fd4cbf4ce10 (patch)
tree19e2a4fe470a96f956c93485d87e1bc986de81b1 /dev-util/itstool
parentmedia-libs/libclxclient-3.9.2: bump (diff)
downloadgentoo-6efd678c2d2720c172a538521d566fd4cbf4ce10.tar.gz
gentoo-6efd678c2d2720c172a538521d566fd4cbf4ce10.tar.bz2
gentoo-6efd678c2d2720c172a538521d566fd4cbf4ce10.zip
dev-util/itstool: bump to 2.0.6, use python3
Bug: https://bugs.gentoo.org/683226 Package-Manager: Portage-2.3.69, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'dev-util/itstool')
-rw-r--r--dev-util/itstool/Manifest1
-rw-r--r--dev-util/itstool/itstool-2.0.6.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-util/itstool/Manifest b/dev-util/itstool/Manifest
index f8df0d9d46c2..892d1eb51f7c 100644
--- a/dev-util/itstool/Manifest
+++ b/dev-util/itstool/Manifest
@@ -1 +1,2 @@
DIST itstool-2.0.2.tar.bz2 96748 BLAKE2B 7eb8f52c233878a35c01b7eea51c46f9700e9de827d38df41bb3ea78ca4ef284ab59c423aaf9876fceef023cb9d13d2d50c9ab57caff9e5fad217363412cf472 SHA512 b7915c4d463fe5969e282029c2080730c78e18d2d5878da53c6a370f471056b51a7b3f3c08417b801212ba674f55548a112a12a9d81634f60d1e52a8a47a4aa2
+DIST itstool-2.0.6.tar.bz2 103067 BLAKE2B 72d3254cb88ef9d02f9b3509a46c2208e98bf6327f139e5d29b99cc6d80651bd41ea3bfb78e48e23cf7c217770cd8c6c74b00946ad9d2608a92925e43457edf0 SHA512 51058bdcb208f6fb84810f71f9bf67e42b00bf157a9756be45f060849c0aff36f695f4403404193720d4446818fa77de61fa94eed9e8789d26c07a2926072eb7
diff --git a/dev-util/itstool/itstool-2.0.6.ebuild b/dev-util/itstool/itstool-2.0.6.ebuild
new file mode 100644
index 000000000000..0cd59f921282
--- /dev/null
+++ b/dev-util/itstool/itstool-2.0.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+PYTHON_REQ_USE="xml"
+
+inherit python-single-r1
+
+DESCRIPTION="Translation tool for XML documents that uses gettext files and ITS rules"
+HOMEPAGE="http://itstool.org/"
+SRC_URI="http://files.itstool.org/itstool/${P}.tar.bz2"
+
+# files in /usr/share/itstool/its are under a special exception || GPL-3+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-linux"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-libs/libxml2[python,${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+BDEPEND=""
+
+DOCS=(ChangeLog NEWS) # AUTHORS, README are empty
+
+src_test() {
+ :
+ #"${PYTHON}" tests/run_tests.py || die "test suite failed" # Test suite not shipped in tarball
+}