summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-12-18 17:50:04 -0500
committerMatt Turner <mattst88@gentoo.org>2021-12-18 18:39:06 -0500
commitb39d0e288d0ecd5c7e2adc6bb0c61432bfdfd16b (patch)
treeb54ae3eb241f4762e42cf5b1a60a1991afe23ebe /dev-util/itstool
parentdev-libs/libdazzle: Version bump to 3.42.0 (diff)
downloadgentoo-b39d0e288d0ecd5c7e2adc6bb0c61432bfdfd16b.tar.gz
gentoo-b39d0e288d0ecd5c7e2adc6bb0c61432bfdfd16b.tar.bz2
gentoo-b39d0e288d0ecd5c7e2adc6bb0c61432bfdfd16b.zip
dev-util/itstool: Version bump to 2.0.7
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-util/itstool')
-rw-r--r--dev-util/itstool/Manifest1
-rw-r--r--dev-util/itstool/itstool-2.0.7.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-util/itstool/Manifest b/dev-util/itstool/Manifest
index 4a22341a356e..db5a31abae7f 100644
--- a/dev-util/itstool/Manifest
+++ b/dev-util/itstool/Manifest
@@ -1 +1,2 @@
DIST itstool-2.0.6.tar.bz2 103067 BLAKE2B 72d3254cb88ef9d02f9b3509a46c2208e98bf6327f139e5d29b99cc6d80651bd41ea3bfb78e48e23cf7c217770cd8c6c74b00946ad9d2608a92925e43457edf0 SHA512 51058bdcb208f6fb84810f71f9bf67e42b00bf157a9756be45f060849c0aff36f695f4403404193720d4446818fa77de61fa94eed9e8789d26c07a2926072eb7
+DIST itstool-2.0.7.tar.bz2 104648 BLAKE2B e2d27d7b0a772596a0fa02b157bbef65b132b839c908c114596d21a54c245a0c941419a3555a8b9b7255800f9ef65d557a5b0f6847103b0a3934c908d43128ab SHA512 710c188e518a7eccbf9d31df59692fd6acc79430589a93ef4333f33f74440c311c340614ca74cc43191830567a98024d0981325ccd83a8fd9b75410d9dd91992
diff --git a/dev-util/itstool/itstool-2.0.7.ebuild b/dev-util/itstool/itstool-2.0.7.ebuild
new file mode 100644
index 000000000000..5305900ab499
--- /dev/null
+++ b/dev-util/itstool/itstool-2.0.7.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="xml"
+
+inherit python-single-r1
+
+DESCRIPTION="Translation tool for XML documents that uses gettext files and ITS rules"
+HOMEPAGE="http://itstool.org/"
+SRC_URI="http://files.itstool.org/itstool/${P}.tar.bz2"
+
+# files in /usr/share/itstool/its are under a special exception || GPL-3+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-libs/libxml2[python,${PYTHON_USEDEP}]
+ ')"
+DEPEND="${RDEPEND}"
+BDEPEND=""
+
+DOCS=(ChangeLog NEWS) # AUTHORS, README are empty
+
+src_test() {
+ :
+ #"${PYTHON}" tests/run_tests.py || die "test suite failed" # Test suite not shipped in tarball
+}