summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/jif
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/jif')
-rw-r--r--dev-util/jif/Manifest1
-rwxr-xr-xdev-util/jif/files/jif9
-rw-r--r--dev-util/jif/jif-3.1_rc1.ebuild62
-rw-r--r--dev-util/jif/metadata.xml13
4 files changed, 85 insertions, 0 deletions
diff --git a/dev-util/jif/Manifest b/dev-util/jif/Manifest
new file mode 100644
index 000000000000..55c35cbb7dde
--- /dev/null
+++ b/dev-util/jif/Manifest
@@ -0,0 +1 @@
+DIST JIF31_src_RC1.zip 261645 SHA256 7c4e2c500fc35dcef3e37af8268c2dd8b47599ef727b90cbd2f912106064e0ea SHA512 167d6c9c5870902209df02b253afd81c07776ee878fccc3dbc9c67834a86f9044f13f6fda5daecf65e26027b57a4fc153e0303b11f5cd0d129f0d291274840cf WHIRLPOOL 84e1b06058ca46340d75be3ad52f8d133c1d0e7943ff97de4ba263cd4b7a403cc08c37b23a5e4766ed92c5558d9b0ec6d57b708e7d1249af280cecfcd3ec07c5
diff --git a/dev-util/jif/files/jif b/dev-util/jif/files/jif
new file mode 100755
index 000000000000..6d6b06ef9205
--- /dev/null
+++ b/dev-util/jif/files/jif
@@ -0,0 +1,9 @@
+#!/bin/sh
+
+wd=`pwd`
+
+cd ${HOME}
+
+java -jar /usr/share/jif/lib/Jif.jar &
+
+cd ${wd}
diff --git a/dev-util/jif/jif-3.1_rc1.ebuild b/dev-util/jif/jif-3.1_rc1.ebuild
new file mode 100644
index 000000000000..124d2702741b
--- /dev/null
+++ b/dev-util/jif/jif-3.1_rc1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit java-pkg-2
+
+MY_PN=${PN/jif/JIF}
+MY_PV=${PV/rc/RC}
+MY_PV=${MY_PV/./}
+MY_PV_MAJOR=${MY_PV/_*/}
+MY_PV_MINOR=${MY_PV/*_/}
+MY_P=${MY_PN}${MY_PV_MAJOR}_src_${MY_PV_MINOR}
+
+IUSE=""
+
+DESCRIPTION="JIF is an IDE for the creation of text adventures based on Graham Nelson's Inform standard"
+HOMEPAGE="http://www.slade.altervista.org/JIF/"
+SRC_URI="http://www.slade.altervista.org/downloads/${MY_P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+
+DEPEND=">=virtual/jdk-1.4
+ >=sys-apps/sed-4.1.4
+ app-arch/unzip"
+
+RDEPEND=">=virtual/jre-1.4
+ >=dev-lang/inform-6.21.4
+ >=games-engines/gargoyle-2010.1"
+
+S=${WORKDIR}/src
+
+src_compile()
+{
+ # Compile classes just as it is done upstream
+ javac -source 1.4 -O -classpath . *.java
+
+ # Adapt default Jif.cfg file to Gentoo
+ sed -i -e "s:\[EXECUTE\]e\,explorer.exe:#\[EXECUTE\]e\,explorer.exe:" Jif.cfg
+ sed -i -e "s:\[EXECUTE\]d\,hh.exe\ C\:\\\Jif\\\doc\\\prova.chm:#\[EXECUTE\]d\,hh.exe\ C\:\\\Jif\\\doc\\\prova.chm:" Jif.cfg
+ sed -i -e "s:C\:\\\Inform\\\Lib\\\Base:/usr/share/inform/6.21/module:" Jif.cfg
+ sed -i -e "s:C\:\\\Inform\\\Lib\\\Contrib::" Jif.cfg
+ sed -i -e "s:C\:\\\Inform\\\Games::" Jif.cfg
+ sed -i -e "s:C\:\\\Inform\\\Bin\\\interpreter\\\Frotz\\\Frotz.exe:/usr/games/bin/frotz:" Jif.cfg
+ sed -i -e "s:C\:\\\Inform\\\Bin\\\interpreter\\\Gargoyle\\\Gargoyle.exe:/usr/bin/gargoyle:" Jif.cfg
+ sed -i -e "s:C\:\\\Inform\\\Bin\\\compiler\\\inform.exe:/usr/bin/inform:" Jif.cfg
+ sed -i -e "s:C\:\\\Inform\\\Bin\\\tools\\\Blorb\\\bres.exe::" Jif.cfg
+ sed -i -e "s:C\:\\\Inform\\\Bin\\\tools\\\Blorb\\\blc.exe::" Jif.cfg
+ sed -i -e "s:Italian,on:Italian,off:" Jif.cfg
+ sed -i -e "s:English,off:English,on:" Jif.cfg
+
+ # Pack them as upstream
+ jar cvfm Jif.jar MANIFEST.MF *.class *.properties images/*.png readme.txt Jif.cfg
+}
+
+src_install()
+{
+ java-pkg_dojar Jif.jar
+ dobin "${FILESDIR}"/jif
+ dodoc CHANGELOG.txt readme.txt
+}
diff --git a/dev-util/jif/metadata.xml b/dev-util/jif/metadata.xml
new file mode 100644
index 000000000000..3f214a6af7d2
--- /dev/null
+++ b/dev-util/jif/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>maintainer-needed@gentoo.org</email>
+</maintainer>
+<longdescription>
+JIF is an Integrated Development Environment (IDE), written entirely in Java,
+for the creation of text adventures based on Graham Nelson's Inform standard.
+With JIF it's possible to edit, compile and run a text adventure in the z-code
+and glulx formats.
+</longdescription>
+</pkgmetadata>