summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/kbuild/kbuild-0.1.9998_pre20120806.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/kbuild/kbuild-0.1.9998_pre20120806.ebuild')
-rw-r--r--dev-util/kbuild/kbuild-0.1.9998_pre20120806.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/dev-util/kbuild/kbuild-0.1.9998_pre20120806.ebuild b/dev-util/kbuild/kbuild-0.1.9998_pre20120806.ebuild
new file mode 100644
index 000000000000..6edec30eb700
--- /dev/null
+++ b/dev-util/kbuild/kbuild-0.1.9998_pre20120806.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils autotools toolchain-funcs
+
+MY_P=kBuild-${PV/_/-}-src
+DESCRIPTION="A makefile framework for writing simple makefiles for complex tasks"
+HOMEPAGE="http://svn.netlabs.org/kbuild/wiki"
+#SRC_URI="ftp://ftp.netlabs.org/pub/${PN}/${MY_P}.tar.gz"
+SRC_URI="http://dev.gentoo.org/~polynomial-c/${MY_P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="sys-devel/flex
+ sys-devel/gettext
+ virtual/yacc"
+RDEPEND=""
+
+S=${WORKDIR}/${MY_P/-src}
+
+src_prepare() {
+ rm -rf "${S}/kBuild/bin"
+
+ epatch "${FILESDIR}/${PN}-unknown-configure-opt.patch" \
+ "${FILESDIR}/${PN}-glibc-2.10.patch" \
+ "${FILESDIR}/${PN}-0.1.5-gentoo-docdir.patch" \
+ "${FILESDIR}/${PN}-0.1.9998_pre20120806-qa.patch" \
+ "${FILESDIR}/${PN}-0.1.9998_pre20110817-kash-link-pthread.patch" \
+ "${FILESDIR}/${PN}-0.1.9998_pre20110817-gold.patch" \
+ "${FILESDIR}/${PN}-0.1.9998_pre20110817-gcc-4.7.patch"
+
+ cd "${S}/src/kmk" || die
+ eautoreconf
+ cd "${S}/src/sed" || die
+ # AM_CONFIG_HEADER is obsolete since automake-1.13 (bug #467104)
+ sed 's@AM_CONFIG_HEADER@AC_CONFIG_HEADERS@' -i configure.ac || die
+ eautoreconf
+
+ sed -e "s@_LDFLAGS\.${ARCH}*.*=@& ${LDFLAGS}@g" \
+ -i "${S}"/Config.kmk || die #332225
+ tc-export CC RANLIB #AR does not work here
+}
+
+src_compile() {
+ kBuild/env.sh --full make -f bootstrap.gmk AUTORECONF=true AR="$(tc-getAR)" \
+ || die "bootstrap failed"
+}
+
+src_install() {
+ kBuild/env.sh kmk NIX_INSTALL_DIR=/usr PATH_INS="${D}" install \
+ || die "install failed"
+}