summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-21 20:55:15 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-21 20:55:15 +0100
commitf20687a3854590e42eefc8eb2f3cff0526198f49 (patch)
treee318bbf9b08954e9ef74563a8c3ce3fe1531ca32 /dev-util/libabigail/libabigail-1.6.ebuild
parentapp-crypt/certbot: update cryptography dep for to 2.8 (diff)
downloadgentoo-f20687a3854590e42eefc8eb2f3cff0526198f49.tar.gz
gentoo-f20687a3854590e42eefc8eb2f3cff0526198f49.tar.bz2
gentoo-f20687a3854590e42eefc8eb2f3cff0526198f49.zip
dev-util/libabigail: Initial commit
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-util/libabigail/libabigail-1.6.ebuild')
-rw-r--r--dev-util/libabigail/libabigail-1.6.ebuild77
1 files changed, 77 insertions, 0 deletions
diff --git a/dev-util/libabigail/libabigail-1.6.ebuild b/dev-util/libabigail/libabigail-1.6.ebuild
new file mode 100644
index 000000000000..639ff46eaed0
--- /dev/null
+++ b/dev-util/libabigail/libabigail-1.6.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+
+inherit autotools python-any-r1 out-of-source
+
+DESCRIPTION="Suite of tools for checking ABI differences between ELF objects"
+HOMEPAGE="https://sourceware.org/libabigail/"
+SRC_URI="https://mirrors.kernel.org/sourceware/libabigail/${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/elfutils:=
+ dev-libs/libxml2:2="
+DEPEND="${RDEPEND}"
+BDEPEND="
+ doc? (
+ app-doc/doxygen
+ dev-python/sphinx
+ sys-apps/texinfo
+ )
+ test? ( ${PYTHON_DEPS} )"
+
+src_prepare() {
+ default
+ # need to run our autotools, due to ltmain.sh including Redhat calls:
+ # cannot read spec file '/usr/lib/rpm/redhat/redhat-hardened-ld': No such file or directory
+ eautoreconf
+}
+
+my_src_configure() {
+ econf \
+ --disable-deb \
+ --disable-fedabipkgdiff \
+ --disable-rpm \
+ --disable-static \
+ --disable-zip-archive \
+ --enable-bash-completion \
+ --enable-cxx11 \
+ --enable-python3 \
+ $(use_enable doc apidoc) \
+ $(use_enable doc manual)
+}
+
+my_src_compile() {
+ default
+ use doc && emake doc
+}
+
+my_src_install() {
+ emake DESTDIR="${D}" install
+
+ if use doc; then
+ doman doc/manuals/man/*
+ doinfo doc/manuals/texinfo/abigail.info
+
+ dodoc -r doc/manuals/html
+
+ docinto html/api
+ dodoc -r doc/api/html/.
+ fi
+}
+
+my_src_install_all() {
+ einstalldocs
+
+ # no static archives
+ find "${D}" -name '*.la' -delete || die
+}