summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-04-19 03:25:58 +0100
committerSam James <sam@gentoo.org>2024-04-19 03:27:37 +0100
commit361bf8db707b2c1cf67db546e7bd734544c8419d (patch)
tree7a0f77c4566990f0638031f60849f5da123da6f7 /dev-util/libabigail
parentdev-python/reportlab: Bump to 4.2.0 (diff)
downloadgentoo-361bf8db707b2c1cf67db546e7bd734544c8419d.tar.gz
gentoo-361bf8db707b2c1cf67db546e7bd734544c8419d.tar.bz2
gentoo-361bf8db707b2c1cf67db546e7bd734544c8419d.zip
dev-util/libabigail: add 2.5
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/libabigail')
-rw-r--r--dev-util/libabigail/Manifest2
-rw-r--r--dev-util/libabigail/libabigail-2.5.ebuild121
-rw-r--r--dev-util/libabigail/libabigail-9999.ebuild3
3 files changed, 125 insertions, 1 deletions
diff --git a/dev-util/libabigail/Manifest b/dev-util/libabigail/Manifest
index fb1527c78e1c..0909ffe631c5 100644
--- a/dev-util/libabigail/Manifest
+++ b/dev-util/libabigail/Manifest
@@ -4,3 +4,5 @@ DIST libabigail-2.3-docs.tar.xz 48016 BLAKE2B 5649dec61017cada11fefcb40d71ecf438
DIST libabigail-2.3.tar.xz 381350984 BLAKE2B 1a580cdc0f60fbf6edbf701e65531fb2b7254232a24edc23600aee49de87eea1c07c4ab93d55c1bce17ce7e0be6e074c7aab83ed6e3aff9076a844c224e52c74 SHA512 fdf0df51e2c262c723c11bef58cd0b89b27e67be196edeb33444fc06e7e61d3c2c227f59cb961aea6fc0c9b7f6f04e08b787a1cbbeb3d5507b968b8ae7630527
DIST libabigail-2.4-docs.tar.xz 50320 BLAKE2B 6e3cc1a8ffc42d0a1307ed57576ec31254d4831ad785b868504ea67310d9a25633403a87b545ee6bcbedb164c7f2ac7fdef307a15a28520daebc505c7da852eb SHA512 48ede7c3b6bab8b26dfdbe3683f4ec6dd9ef0f4626e8bd7b4bc0242795bcad0f7638ee4dee21a65aa3c8f178514aa42223e67ff5a2804c8167db0bcc5bd4a105
DIST libabigail-2.4.tar.xz 357840964 BLAKE2B c3d1c23c598fc8754405df10fcd1cfded6fe80e6949ae9d15ee28e99aad571477b331ceac2aeaa5a93f47da77de7ca41a692902b741e3a4aea1d72a7043d4a91 SHA512 f9b51f8710c75b911da10c1e93e0b6b6fa575f99e8f37a5f51e93a8e6b79c9ad1541e531730b410385053d6565f807300f7910dca48cbd3e991d111198781d95
+DIST libabigail-2.5-docs.tar.xz 54388 BLAKE2B 5d0cdc349955e7d26c6e8655e124ed2b1961bf6da922ab8e77350fc8b0e52a3975a7873bd2d690cd2a7f4110c1c9938a7c1fecf1255d42a7f7b915511038a76f SHA512 cceb0a27031914fa6b02c73810a792bca35ad7b47b688022aa4d15ccbf81549e320b45871a99e7d81c21e10ed8a37ec4e6795662c0dc86f5d6e81dbb7b630856
+DIST libabigail-2.5.tar.xz 364174836 BLAKE2B 0d6515bb7efdccc35b36764ece48ad4afa4d4058a1fb9b51f71e796c73f8080123eefb097ee9bd3f0689e1c2a4b61c6d960792cc04b30a71c199929b344db2ad SHA512 4084ebdd723a8ce1632f70943e29d71328bb695b1b0012ebd3d6ec7edccde872b54e76dfb1bc1c261805919c5e636198cd5bf23baf113474a082db21f2cfdd0d
diff --git a/dev-util/libabigail/libabigail-2.5.ebuild b/dev-util/libabigail/libabigail-2.5.ebuild
new file mode 100644
index 000000000000..0e0b6d252158
--- /dev/null
+++ b/dev-util/libabigail/libabigail-2.5.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Generate using https://github.com/thesamesam/sam-gentoo-scripts/blob/main/niche/generate-libabigail-docs
+# Set to 1 if prebuilt, 0 if not
+# (the construct below is to allow overriding from env for script)
+: ${LIBABIGAIL_DOCS_PREBUILT:=1}
+
+LIBABIGAIL_DOCS_PREBUILT_DEV=sam
+LIBABIGAIL_DOCS_VERSION="${PV}"
+# Default to generating docs (inc. man pages) if no prebuilt; overridden later
+# bug #830088
+LIBABIGAIL_DOCS_USEFLAG="+doc"
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit autotools bash-completion-r1 python-any-r1 out-of-source
+
+DESCRIPTION="Suite of tools for checking ABI differences between ELF objects"
+HOMEPAGE="https://sourceware.org/libabigail/"
+if [[ ${PV} == 9999 ]] ; then
+ LIBABIGAIL_DOCS_PREBUILT=0
+ EGIT_REPO_URI="https://sourceware.org/git/libabigail.git"
+ inherit git-r3
+else
+ SRC_URI="https://mirrors.kernel.org/sourceware/libabigail/${P}.tar.xz"
+ if [[ ${LIBABIGAIL_DOCS_PREBUILT} == 1 ]] ; then
+ SRC_URI+=" !doc? ( https://dev.gentoo.org/~${LIBABIGAIL_DOCS_PREBUILT_DEV}/distfiles/${CATEGORY}/${PN}/${PN}-${LIBABIGAIL_DOCS_VERSION}-docs.tar.xz )"
+ LIBABIGAIL_DOCS_USEFLAG="doc"
+ fi
+
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="Apache-2.0-with-LLVM-exceptions"
+SLOT="0/4"
+IUSE="btf debug ${LIBABIGAIL_DOCS_USEFLAG} test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/elfutils
+ dev-libs/libxml2:2
+ btf? ( dev-libs/libbpf:= )
+ elibc_musl? ( sys-libs/fts-standalone )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ doc? (
+ app-text/doxygen[dot]
+ dev-python/sphinx
+ sys-apps/texinfo
+ )
+ test? ( ${PYTHON_DEPS} )
+"
+
+src_prepare() {
+ default
+ # need to run our autotools, due to ltmain.sh including Redhat calls:
+ # cannot read spec file '/usr/lib/rpm/redhat/redhat-hardened-ld': No such file or directory
+ eautoreconf
+}
+
+my_src_configure() {
+ local myeconfargs=(
+ --disable-abidb
+ --disable-deb
+ --disable-fedabipkgdiff
+ --disable-rpm
+ --disable-rpm415
+ --disable-ctf
+ --disable-debug-ct-propagation
+ # Don't try to run Valgrind on tests.
+ --disable-valgrind
+ --enable-bash-completion
+ --enable-python3
+ $(use_enable debug assert)
+ $(use_enable btf)
+ $(use_enable doc apidoc)
+ $(use_enable doc manual)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+my_src_compile() {
+ default
+ use doc && emake doc
+}
+
+my_src_install() {
+ emake DESTDIR="${D}" install
+
+ # If USE=doc, there'll be newly generated docs which we install instead.
+ if ! use doc && [[ ${LIBABIGAIL_DOCS_PREBUILT} == 1 ]] ; then
+ doinfo "${WORKDIR}"/${PN}-${LIBABIGAIL_DOCS_VERSION}-docs/texinfo/*.info
+ doman "${WORKDIR}"/${PN}-${LIBABIGAIL_DOCS_VERSION}-docs/man/*.[0-8]
+ elif use doc; then
+ doman doc/manuals/man/*
+ doinfo doc/manuals/texinfo/abigail.info
+
+ dodoc -r doc/manuals/html
+
+ docinto html/api
+ dodoc -r doc/api/html/.
+ fi
+}
+
+my_src_install_all() {
+ einstalldocs
+
+ local file
+ for file in abicompat abidiff abidw abilint abinilint abipkgdiff abisym fedabipkgdiff ; do
+ dobashcomp bash-completion/${file}
+ done
+
+ # No static archives
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/dev-util/libabigail/libabigail-9999.ebuild b/dev-util/libabigail/libabigail-9999.ebuild
index 5ca2dece0f9b..0e0b6d252158 100644
--- a/dev-util/libabigail/libabigail-9999.ebuild
+++ b/dev-util/libabigail/libabigail-9999.ebuild
@@ -35,7 +35,7 @@ else
fi
LICENSE="Apache-2.0-with-LLVM-exceptions"
-SLOT="0/3"
+SLOT="0/4"
IUSE="btf debug ${LIBABIGAIL_DOCS_USEFLAG} test"
RESTRICT="!test? ( test )"
@@ -65,6 +65,7 @@ src_prepare() {
my_src_configure() {
local myeconfargs=(
+ --disable-abidb
--disable-deb
--disable-fedabipkgdiff
--disable-rpm