summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-02 13:47:51 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-03 08:04:04 +0200
commitda6ba7c216bc34569f3f8fa23535161b248cdcd4 (patch)
treefea0262ed226e4022405cb8996b8c20883ec0515 /dev-util/lldb
parentsys-devel/lld: Ensure NDEBUG correctly (diff)
downloadgentoo-da6ba7c216bc34569f3f8fa23535161b248cdcd4.tar.gz
gentoo-da6ba7c216bc34569f3f8fa23535161b248cdcd4.tar.bz2
gentoo-da6ba7c216bc34569f3f8fa23535161b248cdcd4.zip
dev-util/lldb: Ensure NDEBUG correctly
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-util/lldb')
-rw-r--r--dev-util/lldb/lldb-13.0.0.9999.ebuild5
-rw-r--r--dev-util/lldb/lldb-13.0.0.ebuild5
-rw-r--r--dev-util/lldb/lldb-14.0.0.9999.ebuild5
3 files changed, 12 insertions, 3 deletions
diff --git a/dev-util/lldb/lldb-13.0.0.9999.ebuild b/dev-util/lldb/lldb-13.0.0.9999.ebuild
index 394b6d66fc57..ce8729bdc598 100644
--- a/dev-util/lldb/lldb-13.0.0.9999.ebuild
+++ b/dev-util/lldb/lldb-13.0.0.9999.ebuild
@@ -12,7 +12,7 @@ HOMEPAGE="https://llvm.org/"
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
SLOT="0"
KEYWORDS=""
-IUSE="+libedit lzma ncurses +python test"
+IUSE="debug +libedit lzma ncurses +python test"
REQUIRED_USE=${PYTHON_REQUIRED_USE}
RESTRICT="test"
@@ -51,6 +51,9 @@ pkg_setup() {
}
src_configure() {
+ # LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
+ use debug || local -x CPPFLAGS="${CPPFLAGS} -DNDEBUG"
+
local mycmakeargs=(
-DLLDB_ENABLE_CURSES=$(usex ncurses)
-DLLDB_ENABLE_LIBEDIT=$(usex libedit)
diff --git a/dev-util/lldb/lldb-13.0.0.ebuild b/dev-util/lldb/lldb-13.0.0.ebuild
index 20f75db4f574..474e09e9cbd1 100644
--- a/dev-util/lldb/lldb-13.0.0.ebuild
+++ b/dev-util/lldb/lldb-13.0.0.ebuild
@@ -12,7 +12,7 @@ HOMEPAGE="https://llvm.org/"
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-IUSE="+libedit lzma ncurses +python test"
+IUSE="debug +libedit lzma ncurses +python test"
REQUIRED_USE=${PYTHON_REQUIRED_USE}
RESTRICT="test"
@@ -51,6 +51,9 @@ pkg_setup() {
}
src_configure() {
+ # LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
+ use debug || local -x CPPFLAGS="${CPPFLAGS} -DNDEBUG"
+
local mycmakeargs=(
-DLLDB_ENABLE_CURSES=$(usex ncurses)
-DLLDB_ENABLE_LIBEDIT=$(usex libedit)
diff --git a/dev-util/lldb/lldb-14.0.0.9999.ebuild b/dev-util/lldb/lldb-14.0.0.9999.ebuild
index 394b6d66fc57..ce8729bdc598 100644
--- a/dev-util/lldb/lldb-14.0.0.9999.ebuild
+++ b/dev-util/lldb/lldb-14.0.0.9999.ebuild
@@ -12,7 +12,7 @@ HOMEPAGE="https://llvm.org/"
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
SLOT="0"
KEYWORDS=""
-IUSE="+libedit lzma ncurses +python test"
+IUSE="debug +libedit lzma ncurses +python test"
REQUIRED_USE=${PYTHON_REQUIRED_USE}
RESTRICT="test"
@@ -51,6 +51,9 @@ pkg_setup() {
}
src_configure() {
+ # LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
+ use debug || local -x CPPFLAGS="${CPPFLAGS} -DNDEBUG"
+
local mycmakeargs=(
-DLLDB_ENABLE_CURSES=$(usex ncurses)
-DLLDB_ENABLE_LIBEDIT=$(usex libedit)