summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2021-03-11 07:58:29 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2021-03-11 07:58:43 +0000
commit88a7537e01bf74739ffe3f63a5e9a929646e3053 (patch)
tree43231e26643974c1145bd1bcb1f84176c0666bb7 /dev-util/ltrace
parentwww-apache/mod_xsendfile: EAPI=7, fix docs, become maintainer (diff)
downloadgentoo-88a7537e01bf74739ffe3f63a5e9a929646e3053.tar.gz
gentoo-88a7537e01bf74739ffe3f63a5e9a929646e3053.tar.bz2
gentoo-88a7537e01bf74739ffe3f63a5e9a929646e3053.zip
dev-util/ltrace: disable munmap test, disable sandbox
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-util/ltrace')
-rw-r--r--dev-util/ltrace/files/ltrace-0.7.3-disable-munmap-test.patch15
-rw-r--r--dev-util/ltrace/ltrace-0.7.3_p4-r1.ebuild7
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-util/ltrace/files/ltrace-0.7.3-disable-munmap-test.patch b/dev-util/ltrace/files/ltrace-0.7.3-disable-munmap-test.patch
new file mode 100644
index 000000000000..fdd7412efeda
--- /dev/null
+++ b/dev-util/ltrace/files/ltrace-0.7.3-disable-munmap-test.patch
@@ -0,0 +1,15 @@
+--- a/testsuite/ltrace.main/system_calls.exp
++++ b/testsuite/ltrace.main/system_calls.exp
+@@ -29,8 +29,10 @@ if [regexp {ELF from incompatible architecture} $exec_output] {
+ }
+
+
+-set pattern "SYS_munmap"
+-ltrace_verify_output ${objdir}/${subdir}/${testfile}.ltrace $pattern 2
++## disabled in Gentoo: libc's stdio tends to call (or not to call) munmap
++## depending on heuristics of stdio buffer sizes.
++##set pattern "SYS_munmap"
++##ltrace_verify_output ${objdir}/${subdir}/${testfile}.ltrace $pattern 2
+ set pattern "SYS_write"
+ ltrace_verify_output ${objdir}/${subdir}/${testfile}.ltrace $pattern 1
+ set pattern "SYS_unlink"
diff --git a/dev-util/ltrace/ltrace-0.7.3_p4-r1.ebuild b/dev-util/ltrace/ltrace-0.7.3_p4-r1.ebuild
index 8f9f97e7fb45..beb325aa49c3 100644
--- a/dev-util/ltrace/ltrace-0.7.3_p4-r1.ebuild
+++ b/dev-util/ltrace/ltrace-0.7.3_p4-r1.ebuild
@@ -48,6 +48,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-0.7.3-tuple-tests.patch
"${FILESDIR}"/${PN}-0.7.3-CXX-for-tests.patch
"${FILESDIR}"/${PN}-0.7.3-test-glibc-2.33.patch
+ "${FILESDIR}"/${PN}-0.7.3-disable-munmap-test.patch
)
src_prepare() {
@@ -67,3 +68,9 @@ src_configure() {
$(use_enable debug) \
$(use_with unwind libunwind)
}
+
+src_test() {
+ # sandbox redirects vfork() to fork(): bug # 774054
+ # Let's avoid sandbox entirely.
+ SANDBOX_ON=0 LD_PRELOAD= emake check
+}