summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2019-10-23 17:39:26 +0800
committerYixun Lan <dlan@gentoo.org>2019-10-23 17:39:26 +0800
commitb0efdb5d0439229dd5e3b5d9dca471d36e6efb88 (patch)
tree145e17c33d159aaf7fa4805892e644580cfe7331 /dev-util/lttng-ust/lttng-ust-2.10.6.ebuild
parentdev-util/lttng-modules: drop old (diff)
downloadgentoo-b0efdb5d0439229dd5e3b5d9dca471d36e6efb88.tar.gz
gentoo-b0efdb5d0439229dd5e3b5d9dca471d36e6efb88.tar.bz2
gentoo-b0efdb5d0439229dd5e3b5d9dca471d36e6efb88.zip
dev-util/lttng-ust: version bump, 2.10.6
Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'dev-util/lttng-ust/lttng-ust-2.10.6.ebuild')
-rw-r--r--dev-util/lttng-ust/lttng-ust-2.10.6.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-util/lttng-ust/lttng-ust-2.10.6.ebuild b/dev-util/lttng-ust/lttng-ust-2.10.6.ebuild
new file mode 100644
index 000000000000..ead5c2518d16
--- /dev/null
+++ b/dev-util/lttng-ust/lttng-ust-2.10.6.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+MY_P="${P/_rc/-rc}"
+MY_SLOT="$(ver_cut 1-2)"
+
+DESCRIPTION="Linux Trace Toolkit - UST library"
+HOMEPAGE="http://lttng.org"
+SRC_URI="http://lttng.org/files/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0/${MY_SLOT}"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="examples"
+
+DEPEND="dev-libs/userspace-rcu:="
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/${MY_P}
+
+src_prepare() {
+ default
+ if ! use examples; then
+ sed -i -e '/SUBDIRS/s:examples::' doc/Makefile.am || die
+ fi
+ eautoreconf
+}
+
+src_configure() {
+ econf --docdir=/usr/share/doc/${PF}
+}