summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2019-10-22 09:57:05 +0000
committerYixun Lan <dlan@gentoo.org>2019-10-22 09:57:05 +0000
commitb7315ea61354ac289ef75f34e766f91956d597c3 (patch)
tree528991d63784259e8af89ca95bd3a4b300ab54ad /dev-util/lttng-ust/lttng-ust-2.11.0.ebuild
parentdev-util/lttng-modules: version bump, 2.11.0 (diff)
downloadgentoo-b7315ea61354ac289ef75f34e766f91956d597c3.tar.gz
gentoo-b7315ea61354ac289ef75f34e766f91956d597c3.tar.bz2
gentoo-b7315ea61354ac289ef75f34e766f91956d597c3.zip
dev-util/lttng-ust: version bump, 2.11.0
Package-Manager: Portage-2.3.77, Repoman-2.3.17 Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'dev-util/lttng-ust/lttng-ust-2.11.0.ebuild')
-rw-r--r--dev-util/lttng-ust/lttng-ust-2.11.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-util/lttng-ust/lttng-ust-2.11.0.ebuild b/dev-util/lttng-ust/lttng-ust-2.11.0.ebuild
new file mode 100644
index 000000000000..ead5c2518d16
--- /dev/null
+++ b/dev-util/lttng-ust/lttng-ust-2.11.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+MY_P="${P/_rc/-rc}"
+MY_SLOT="$(ver_cut 1-2)"
+
+DESCRIPTION="Linux Trace Toolkit - UST library"
+HOMEPAGE="http://lttng.org"
+SRC_URI="http://lttng.org/files/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0/${MY_SLOT}"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="examples"
+
+DEPEND="dev-libs/userspace-rcu:="
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/${MY_P}
+
+src_prepare() {
+ default
+ if ! use examples; then
+ sed -i -e '/SUBDIRS/s:examples::' doc/Makefile.am || die
+ fi
+ eautoreconf
+}
+
+src_configure() {
+ econf --docdir=/usr/share/doc/${PF}
+}