summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2016-02-18 14:50:30 +0800
committerYixun Lan <dlan@gentoo.org>2016-02-18 15:43:31 +0800
commit2ce3ceeb1f6dd8a80715e72a0596cbfaf8145e7c (patch)
tree6be5230d48ee9b745c3ce09bab1ae1589b17e411 /dev-util/lttng-ust/lttng-ust-2.7.1.ebuild
parentdev-ruby/kramdown: add 1.9.0 (diff)
downloadgentoo-2ce3ceeb1f6dd8a80715e72a0596cbfaf8145e7c.tar.gz
gentoo-2ce3ceeb1f6dd8a80715e72a0596cbfaf8145e7c.tar.bz2
gentoo-2ce3ceeb1f6dd8a80715e72a0596cbfaf8145e7c.zip
ev-util/lttng-ust: version bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-util/lttng-ust/lttng-ust-2.7.1.ebuild')
-rw-r--r--dev-util/lttng-ust/lttng-ust-2.7.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-util/lttng-ust/lttng-ust-2.7.1.ebuild b/dev-util/lttng-ust/lttng-ust-2.7.1.ebuild
new file mode 100644
index 000000000000..c3f261f5db6c
--- /dev/null
+++ b/dev-util/lttng-ust/lttng-ust-2.7.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools versionator
+
+MY_P="${P/_rc/-rc}"
+MY_SLOT="$(get_version_component_range 1-2)"
+
+DESCRIPTION="Linux Trace Toolkit - UST library"
+HOMEPAGE="http://lttng.org"
+SRC_URI="http://lttng.org/files/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0/${MY_SLOT}"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="examples"
+
+DEPEND="dev-libs/userspace-rcu"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/${MY_P}
+
+src_prepare() {
+ if ! use examples; then
+ sed -i -e '/SUBDIRS/s:examples::' doc/Makefile.am || die
+ fi
+ eautoreconf
+}