summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/lttng-ust
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/lttng-ust')
-rw-r--r--dev-util/lttng-ust/Manifest3
-rw-r--r--dev-util/lttng-ust/lttng-ust-2.5.0.ebuild27
-rw-r--r--dev-util/lttng-ust/lttng-ust-2.5.1.ebuild27
-rw-r--r--dev-util/lttng-ust/lttng-ust-2.6.0_rc2.ebuild29
-rw-r--r--dev-util/lttng-ust/metadata.xml12
5 files changed, 98 insertions, 0 deletions
diff --git a/dev-util/lttng-ust/Manifest b/dev-util/lttng-ust/Manifest
new file mode 100644
index 000000000000..dabba7ec1bc2
--- /dev/null
+++ b/dev-util/lttng-ust/Manifest
@@ -0,0 +1,3 @@
+DIST lttng-ust-2.5.0.tar.bz2 583293 SHA256 dcd0bb81a12833e6edea110a0cc97108a7e55b1dc95ff2c97d06796866f5c3aa SHA512 15e614a0b66d668e00de56275f80f67a3ee159642e06a5c2981ac3bd2266c0f3c2cbad8dd3e4b5158ef85070bdcf9b513e17de346dbc628878c2de68768dd634 WHIRLPOOL 3cac7a2d905a2ab913220d13ffd295e442e7e0b676b68e501542b799092a7d6d8e45211fd8cf98939478958aee739e86041b797229207820172cce2726c86677
+DIST lttng-ust-2.5.1.tar.bz2 589487 SHA256 fbd9e2d78641e5c659f1d51f8097c8279c155ff50f8e38a4c57f188ca4b84546 SHA512 718f0f50077ed7d1c9647de7714c237fde619ea23de8160af508fd1e6a60fb3594b0424b93a7ad5cbc47f4106721e7ef75ea82f1976a0a8fbf3305e8179769b6 WHIRLPOOL 38ea8fbdc6461f3a8af914b289cf8496c6a6fa48efcb0ed29be6f404310624602e7b8402b3ec2ad89a2a45c1a441afc162e83b09ecd9cd3654cf1e2638599575
+DIST lttng-ust-2.6.0-rc2.tar.bz2 608934 SHA256 664fabe883c863f8ba1f83b2fa030c097181aed44bd75979431c0fc0e1e71598 SHA512 a7ccf10e03693397168cca34b5008609a2c6dbf1bd88b84e42014861af432379efdbb040a31c77bf20014838d491fcb05ab67ca47c6924c7f74ca539c3019f3b WHIRLPOOL 7fd15c99e57cc21c6d9ce46ecab07da2389a2364d7de5a0b34357465a404bbd15d756d4ce54460ae52a923bb644e6719fcf4527773400e2aeef4c1a70bf84c5f
diff --git a/dev-util/lttng-ust/lttng-ust-2.5.0.ebuild b/dev-util/lttng-ust/lttng-ust-2.5.0.ebuild
new file mode 100644
index 000000000000..88522a591bec
--- /dev/null
+++ b/dev-util/lttng-ust/lttng-ust-2.5.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools
+
+MY_P="${P/_rc/-rc}"
+DESCRIPTION="Linux Trace Toolkit - UST library"
+HOMEPAGE="http://lttng.org"
+SRC_URI="http://lttng.org/files/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="examples"
+
+DEPEND="dev-libs/userspace-rcu"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ if ! use examples; then
+ sed -i -e '/SUBDIRS/s:examples::' doc/Makefile.am || die
+ fi
+ eautoreconf
+}
diff --git a/dev-util/lttng-ust/lttng-ust-2.5.1.ebuild b/dev-util/lttng-ust/lttng-ust-2.5.1.ebuild
new file mode 100644
index 000000000000..88522a591bec
--- /dev/null
+++ b/dev-util/lttng-ust/lttng-ust-2.5.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools
+
+MY_P="${P/_rc/-rc}"
+DESCRIPTION="Linux Trace Toolkit - UST library"
+HOMEPAGE="http://lttng.org"
+SRC_URI="http://lttng.org/files/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="examples"
+
+DEPEND="dev-libs/userspace-rcu"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ if ! use examples; then
+ sed -i -e '/SUBDIRS/s:examples::' doc/Makefile.am || die
+ fi
+ eautoreconf
+}
diff --git a/dev-util/lttng-ust/lttng-ust-2.6.0_rc2.ebuild b/dev-util/lttng-ust/lttng-ust-2.6.0_rc2.ebuild
new file mode 100644
index 000000000000..136b7571b825
--- /dev/null
+++ b/dev-util/lttng-ust/lttng-ust-2.6.0_rc2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools
+
+MY_P="${P/_rc/-rc}"
+DESCRIPTION="Linux Trace Toolkit - UST library"
+HOMEPAGE="http://lttng.org"
+SRC_URI="http://lttng.org/files/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="examples"
+
+DEPEND="dev-libs/userspace-rcu"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/${MY_P}
+
+src_prepare() {
+ if ! use examples; then
+ sed -i -e '/SUBDIRS/s:examples::' doc/Makefile.am || die
+ fi
+ eautoreconf
+}
diff --git a/dev-util/lttng-ust/metadata.xml b/dev-util/lttng-ust/metadata.xml
new file mode 100644
index 000000000000..1c98ff2ecd20
--- /dev/null
+++ b/dev-util/lttng-ust/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>dlan@gentoo.org</email>
+ <name>Yixun Lan</name>
+ </maintainer>
+
+ <longdescription>
+ The userspace tracer is designed to provide detailed information about userspace activity. UST is a port of the LTTng kernel tracer to userspace. Like the LTTng kernel tracer, performance is the main goal. Tracing does not require system calls or traps. UST instrumentation points may be added in any userspace code including signal handlers and libraries­.
+ </longdescription>
+</pkgmetadata>