summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2019-10-23 10:23:54 +0800
committerYixun Lan <dlan@gentoo.org>2019-10-23 10:23:54 +0800
commit8c78790af05f79450173f4c26b97657338cd039e (patch)
treecac02a9b8e76e3dcda5309d3b807d1739c7869b6 /dev-util/lttng-ust
parentdev-util/vulkan-tools: Fix remaining incorrect dep (diff)
downloadgentoo-8c78790af05f79450173f4c26b97657338cd039e.tar.gz
gentoo-8c78790af05f79450173f4c26b97657338cd039e.tar.bz2
gentoo-8c78790af05f79450173f4c26b97657338cd039e.zip
dev-util/lttng-ust: fix missing numa dependency error
Closes: https://bugs.gentoo.org/698296 Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'dev-util/lttng-ust')
-rw-r--r--dev-util/lttng-ust/lttng-ust-2.11.0.ebuild11
-rw-r--r--dev-util/lttng-ust/metadata.xml4
2 files changed, 11 insertions, 4 deletions
diff --git a/dev-util/lttng-ust/lttng-ust-2.11.0.ebuild b/dev-util/lttng-ust/lttng-ust-2.11.0.ebuild
index ead5c2518d16..ecc26c91c8ac 100644
--- a/dev-util/lttng-ust/lttng-ust-2.11.0.ebuild
+++ b/dev-util/lttng-ust/lttng-ust-2.11.0.ebuild
@@ -15,9 +15,12 @@ SRC_URI="http://lttng.org/files/${PN}/${MY_P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0/${MY_SLOT}"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
-IUSE="examples"
+IUSE="examples numa"
-DEPEND="dev-libs/userspace-rcu:="
+DEPEND="
+ dev-libs/userspace-rcu:=
+ numa? ( sys-process/numactl )
+ "
RDEPEND="${DEPEND}"
S="${WORKDIR}"/${MY_P}
@@ -31,5 +34,7 @@ src_prepare() {
}
src_configure() {
- econf --docdir=/usr/share/doc/${PF}
+ econf \
+ $(use_enable numa) \
+ --docdir=/usr/share/doc/${PF}
}
diff --git a/dev-util/lttng-ust/metadata.xml b/dev-util/lttng-ust/metadata.xml
index 6c50e4708494..2b073ed00322 100644
--- a/dev-util/lttng-ust/metadata.xml
+++ b/dev-util/lttng-ust/metadata.xml
@@ -5,7 +5,9 @@
<email>dlan@gentoo.org</email>
<name>Yixun Lan</name>
</maintainer>
-
+ <use>
+ <flag name="numa">Enable numa support</flag>
+ </use>
<longdescription>
The userspace tracer is designed to provide detailed information about userspace activity. UST is a port of the LTTng kernel tracer to userspace. Like the LTTng kernel tracer, performance is the main goal. Tracing does not require system calls or traps. UST instrumentation points may be added in any userspace code including signal handlers and libraries.
</longdescription>