summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-02-17 20:14:32 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2020-02-17 20:14:53 +0000
commite652e01f35129b584502ac6367de13cfbf1b528c (patch)
tree4a12660cbb8be1dfe9898f11fc576a07f8692c5b /dev-util/lttng-ust
parentdev-python/attrs: stable 19.3.0 for hppa, bug #703062 (diff)
downloadgentoo-e652e01f35129b584502ac6367de13cfbf1b528c.tar.gz
gentoo-e652e01f35129b584502ac6367de13cfbf1b528c.tar.bz2
gentoo-e652e01f35129b584502ac6367de13cfbf1b528c.zip
dev-util/lttng-ust: backport gcc-10 fix, bug #706862
Reported-by: Toralf Förster Closes: https://bugs.gentoo.org/706862 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-util/lttng-ust')
-rw-r--r--dev-util/lttng-ust/files/lttng-ust-2.11.0-fno-common.patch47
-rw-r--r--dev-util/lttng-ust/lttng-ust-2.11.0.ebuild4
2 files changed, 50 insertions, 1 deletions
diff --git a/dev-util/lttng-ust/files/lttng-ust-2.11.0-fno-common.patch b/dev-util/lttng-ust/files/lttng-ust-2.11.0-fno-common.patch
new file mode 100644
index 000000000000..48b5bfbbe39c
--- /dev/null
+++ b/dev-util/lttng-ust/files/lttng-ust-2.11.0-fno-common.patch
@@ -0,0 +1,47 @@
+From 21a934df4c683e73e0a66a9afca33573fcf9d789 Mon Sep 17 00:00:00 2001
+From: Michael Jeanson <mjeanson@efficios.com>
+Date: Thu, 16 Jan 2020 10:59:14 -0500
+Subject: [PATCH] Fix: build with -fno-common
+
+GCC 10 will default to building with -fno-common, this inhibits the
+linker from merging multiple tentative definitions of a symbol in an
+archive. Keep only the declaration in the libustsnprintf.la convenience
+library.
+
+Signed-off-by: Michael Jeanson <mjeanson@efficios.com>
+Signed-off-by: Mathieu Desnoyers <mathieu.desnoyers@efficios.com>
+Change-Id: I8fb7c72811ce7e62f10342f55fcabeeabfdd4c67
+---
+ liblttng-ust-ctl/ustctl.c | 2 --
+ liblttng-ust-fd/lttng-ust-fd.c | 2 --
+ 2 files changed, 4 deletions(-)
+
+diff --git a/liblttng-ust-ctl/ustctl.c b/liblttng-ust-ctl/ustctl.c
+index 949ece17..c2b761a1 100644
+--- a/liblttng-ust-ctl/ustctl.c
++++ b/liblttng-ust-ctl/ustctl.c
+@@ -77,8 +77,6 @@ extern void lttng_ring_buffer_client_discard_exit(void);
+ extern void lttng_ring_buffer_client_discard_rt_exit(void);
+ extern void lttng_ring_buffer_metadata_client_exit(void);
+
+-volatile enum ust_loglevel ust_loglevel;
+-
+ int ustctl_release_handle(int sock, int handle)
+ {
+ struct ustcomm_ust_msg lum;
+diff --git a/liblttng-ust-fd/lttng-ust-fd.c b/liblttng-ust-fd/lttng-ust-fd.c
+index 863f0618..4818e02e 100644
+--- a/liblttng-ust-fd/lttng-ust-fd.c
++++ b/liblttng-ust-fd/lttng-ust-fd.c
+@@ -28,8 +28,6 @@
+ #include <helper.h>
+ #include "usterr-signal-safe.h"
+
+-volatile enum ust_loglevel ust_loglevel;
+-
+ static int (*__lttng_ust_fd_plibc_close)(int fd);
+ static int (*__lttng_ust_fd_plibc_fclose)(FILE *stream);
+
+--
+2.25.0
+
diff --git a/dev-util/lttng-ust/lttng-ust-2.11.0.ebuild b/dev-util/lttng-ust/lttng-ust-2.11.0.ebuild
index ecc26c91c8ac..a3aa0dbf6f7d 100644
--- a/dev-util/lttng-ust/lttng-ust-2.11.0.ebuild
+++ b/dev-util/lttng-ust/lttng-ust-2.11.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -23,6 +23,8 @@ DEPEND="
"
RDEPEND="${DEPEND}"
+PATCHES=("${FILESDIR}"/${P}-fno-common.patch)
+
S="${WORKDIR}"/${MY_P}
src_prepare() {