summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/makeheaders
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/makeheaders')
-rw-r--r--dev-util/makeheaders/Manifest2
-rw-r--r--dev-util/makeheaders/makeheaders-0_p4.ebuild36
-rw-r--r--dev-util/makeheaders/metadata.xml9
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-util/makeheaders/Manifest b/dev-util/makeheaders/Manifest
new file mode 100644
index 000000000000..5595b04671c6
--- /dev/null
+++ b/dev-util/makeheaders/Manifest
@@ -0,0 +1,2 @@
+DIST makeheaders-0_p4.c 99253 SHA256 a03498d80e29c836b1525cd2aad7f2f75c80e8dfcd533dd619ac0fe0c5cef2cd SHA512 d46a23a4ee1436f1bad2f0d26e7de9be47a84b0c163430bdaf360c4c6a94b84949f2a427683265898312e56e9dda316992857e488202aa74afcc3939fa712a35 WHIRLPOOL 7ac59e936cd81923024ce27b82561ce6eaffe56abd20f1f419cc8373644312ff331be0edc5649ee6f327772188ee6667696f70934ef3118c58e36e2e407e24b5
+DIST makeheaders-0_p4.html 35481 SHA256 dad57fe035cf440d28878ff31ae30a188b8935aeb68f3f6ee08f3001a1c19008 SHA512 903437c9d4b280af1cb9d5e29df150fb347ef9c62ec146daecfb5c4093554531c206bc73885cc7aacea1b7c24fb473e240a03a31c139caf6bc0e42901b518597 WHIRLPOOL 548d486201d2bcdc8c2445e986e55a904c237e41b99f229a91cb6e19c9ecb95ea5a8b1f529d8bc536e2feb210ee4f1e2ee7cbd04ab30a18aeb008620e2e01c30
diff --git a/dev-util/makeheaders/makeheaders-0_p4.ebuild b/dev-util/makeheaders/makeheaders-0_p4.ebuild
new file mode 100644
index 000000000000..8196522e2d83
--- /dev/null
+++ b/dev-util/makeheaders/makeheaders-0_p4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+inherit toolchain-funcs
+
+DESCRIPTION="simple utility that will automatically generate header files"
+HOMEPAGE="http://www.hwaci.com/sw/mkhdr/"
+SRC_URI="http://www.hwaci.com/sw/mkhdr/makeheaders.c -> ${P}.c
+ http://www.hwaci.com/sw/mkhdr/makeheaders.html -> ${P}.html"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~sparc x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ local my_a
+ for my_a in ${A} ; do
+ cp -v "${DISTDIR}"/"${my_a}" . || die
+ done
+}
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} -o ${PN} ${P}.c ${LDFLAGS} || die
+}
+
+src_install() {
+ dobin ${PN} || die
+ dohtml ${P}.html || die
+}
diff --git a/dev-util/makeheaders/metadata.xml b/dev-util/makeheaders/metadata.xml
new file mode 100644
index 000000000000..59acc2cc580e
--- /dev/null
+++ b/dev-util/makeheaders/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>xmw@gentoo.org</email>
+<name>Michael Weber</name>
+</maintainer>
+</pkgmetadata>
+