summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2016-08-20 11:15:56 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-09-17 23:32:12 +0200
commit5e503dc1bc242bb9270621024de47314e2770c91 (patch)
tree6579d6928530c00a6cae46604e21586058b0417e /dev-util/mdds/mdds-1.2.2.ebuild
parentapp-text/libmwaw: Version bump to 0.3.8 (diff)
downloadgentoo-5e503dc1bc242bb9270621024de47314e2770c91.tar.gz
gentoo-5e503dc1bc242bb9270621024de47314e2770c91.tar.bz2
gentoo-5e503dc1bc242bb9270621024de47314e2770c91.zip
dev-util/mdds: Version bump to 1.2.2
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-util/mdds/mdds-1.2.2.ebuild')
-rw-r--r--dev-util/mdds/mdds-1.2.2.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-util/mdds/mdds-1.2.2.ebuild b/dev-util/mdds/mdds-1.2.2.ebuild
new file mode 100644
index 000000000000..1cef7df4bf22
--- /dev/null
+++ b/dev-util/mdds/mdds-1.2.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+EGIT_REPO_URI="https://gitlab.com/mdds/mdds.git"
+[[ ${PV} == 9999 ]] && GITECLASS="git-r3 autotools"
+
+inherit eutils toolchain-funcs ${GITECLASS}
+
+DESCRIPTION="A collection of multi-dimensional data structure and indexing algorithm"
+HOMEPAGE="https://gitlab.com/mdds/mdds"
+[[ ${PV} == 9999 ]] || SRC_URI="http://kohei.us/files/${PN}/src/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="1/${PV%.*}"
+IUSE="doc valgrind"
+
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="dev-libs/boost:="
+DEPEND="${RDEPEND}
+ doc? (
+ app-doc/doxygen
+ dev-python/sphinx
+ )
+"
+
+DOCS=() # buildsystem installs docs
+
+src_prepare(){
+ eapply_user
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable doc docs) \
+ $(use_enable valgrind memory_tests)
+}
+
+src_compile() { :; }
+
+src_test() {
+ tc-export CXX
+ default
+}