summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2015-12-11 01:48:52 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-02-22 18:04:34 +0100
commita1faf530837d0e986c2a75abd905aef5b26b51b9 (patch)
treeae94012e1ad4b07eb5712133d315f828818b4eb3 /dev-util/mdds/mdds-9999.ebuild
parentmedia-sound/ardour: bump to 4.7 (diff)
downloadgentoo-a1faf530837d0e986c2a75abd905aef5b26b51b9.tar.gz
gentoo-a1faf530837d0e986c2a75abd905aef5b26b51b9.tar.bz2
gentoo-a1faf530837d0e986c2a75abd905aef5b26b51b9.zip
dev-util/mdds: 1.1.0 version bump, bug 572616
mdds:1 installs side-by-side with mdds:0. At this point, LibreOffice live both depends on mdds:1 and through libixion-0.9* indirectly pulls in :0. Package-Manager: portage-2.2.24
Diffstat (limited to 'dev-util/mdds/mdds-9999.ebuild')
-rw-r--r--dev-util/mdds/mdds-9999.ebuild25
1 files changed, 16 insertions, 9 deletions
diff --git a/dev-util/mdds/mdds-9999.ebuild b/dev-util/mdds/mdds-9999.ebuild
index e0db9959c3b9..754707aed497 100644
--- a/dev-util/mdds/mdds-9999.ebuild
+++ b/dev-util/mdds/mdds-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
EGIT_REPO_URI="https://gitlab.com/mdds/mdds.git"
[[ ${PV} == 9999 ]] && GITECLASS="git-r3 autotools"
@@ -11,27 +11,34 @@ inherit eutils toolchain-funcs ${GITECLASS}
DESCRIPTION="A collection of multi-dimensional data structure and indexing algorithm"
HOMEPAGE="https://gitlab.com/mdds/mdds"
-[[ ${PV} == 9999 ]] || SRC_URI="http://kohei.us/files/${PN}/src/${P/-/_}.tar.bz2"
+[[ ${PV} == 9999 ]] || SRC_URI="http://kohei.us/files/${PN}/src/${P}.tar.bz2"
LICENSE="MIT"
-SLOT="0/${PV}"
-IUSE=""
+SLOT="1/${PV}"
+IUSE="doc valgrind"
[[ ${PV} == 9999 ]] || \
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-DEPEND="dev-libs/boost:="
-RDEPEND="${DEPEND}"
+COMMON_DEPEND="dev-libs/boost:="
+DEPEND="${COMMON_DEPEND}
+ doc? (
+ app-doc/doxygen
+ dev-python/sphinx
+ )"
+RDEPEND="${COMMON_DEPEND}"
-[[ ${PV} == 9999 ]] || S=${WORKDIR}/${P/-/_}
+DOCS=() # buildsystem installs docs
src_prepare(){
+ eapply_user
[[ ${PV} == 9999 ]] && eautoreconf
}
src_configure() {
econf \
- --with-hash-container=boost \
+ $(use_enable doc docs) \
+ $(use_enable valgrind memory_tests) \
--docdir="${EPREFIX}/usr/share/doc/${PF}"
}