summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-11-15 23:49:43 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-11-16 00:12:15 +0100
commit3785c594bec3e9e3ae518ad1f13cf7bca16c1f69 (patch)
tree8f9d785a07c06a119e1d890b888c8e853f0d0db7 /dev-util/mdds
parentapp-text/libodfgen: 0.1.7 version bump (diff)
downloadgentoo-3785c594bec3e9e3ae518ad1f13cf7bca16c1f69.tar.gz
gentoo-3785c594bec3e9e3ae518ad1f13cf7bca16c1f69.tar.bz2
gentoo-3785c594bec3e9e3ae518ad1f13cf7bca16c1f69.zip
dev-util/mdds: EAPI-7 bump
Rebase buildsystem patch. Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-util/mdds')
-rw-r--r--dev-util/mdds/files/mdds-1.4.3-buildsystem.patch36
-rw-r--r--dev-util/mdds/mdds-9999.ebuild25
2 files changed, 49 insertions, 12 deletions
diff --git a/dev-util/mdds/files/mdds-1.4.3-buildsystem.patch b/dev-util/mdds/files/mdds-1.4.3-buildsystem.patch
new file mode 100644
index 000000000000..ef3616d6f2fb
--- /dev/null
+++ b/dev-util/mdds/files/mdds-1.4.3-buildsystem.patch
@@ -0,0 +1,36 @@
+We want to install (not all of) those files manually.
+
+--- a/Makefile.am 2018-08-29 13:23:49.434860594 +0200
++++ b/Makefile.am 2018-08-29 13:25:52.125789186 +0200
+@@ -4,7 +4,6 @@
+
+ AM_CPPFLAGS = -I$(top_srcdir)/include $(CXXFLAGS_UNITTESTS)
+
+-dist_doc_DATA = AUTHORS README.md
+ nodist_pkgconf_DATA = misc/mdds-@API_VERSION@.pc
+
+ DISTCLEANFILES = \
+@@ -15,8 +14,6 @@
+
+ EXTRA_DIST = \
+ autogen.sh \
+- CHANGELOG \
+- LICENSE \
+ doc/conf.py \
+ doc/doxygen.conf \
+ doc/flat_segment_tree.rst \
+@@ -164,14 +161,6 @@
+ rtree_test_bulkload_mem.mem
+ endif
+
+-install-data-local:
+- $(MKDIR_P) $(DESTDIR)$(docdir)
+- $(INSTALL_DATA) $(top_srcdir)/LICENSE $(DESTDIR)$(docdir)/COPYING
+- $(INSTALL_DATA) $(top_srcdir)/CHANGELOG $(DESTDIR)$(docdir)/NEWS
+-
+-uninstall-local:
+- rm -f $(DESTDIR)$(docdir)/COPYING $(DESTDIR)$(docdir)/NEWS
+-
+ if BUILD_DOCS
+ html-local:
+ (cd doc && $(DOXYGEN) doxygen.conf)
diff --git a/dev-util/mdds/mdds-9999.ebuild b/dev-util/mdds/mdds-9999.ebuild
index 65b5df3e9c0e..facdbc17f0d4 100644
--- a/dev-util/mdds/mdds-9999.ebuild
+++ b/dev-util/mdds/mdds-9999.ebuild
@@ -1,26 +1,27 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-EGIT_REPO_URI="https://gitlab.com/mdds/mdds.git"
-[[ ${PV} == 9999 ]] && GITECLASS="git-r3"
-
-inherit autotools toolchain-funcs ${GITECLASS}
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://gitlab.com/mdds/mdds.git"
+ inherit git-r3
+else
+ SRC_URI="https://kohei.us/files/${PN}/src/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+fi
+inherit autotools toolchain-funcs
DESCRIPTION="A collection of multi-dimensional data structure and indexing algorithm"
HOMEPAGE="https://gitlab.com/mdds/mdds"
-[[ ${PV} == 9999 ]] || SRC_URI="https://kohei.us/files/${PN}/src/${P}.tar.bz2"
LICENSE="MIT"
SLOT="1/${PV%.*}"
IUSE="doc valgrind"
-[[ ${PV} == 9999 ]] || \
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-
RDEPEND="dev-libs/boost:="
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
doc? (
app-doc/doxygen
dev-python/sphinx
@@ -28,7 +29,7 @@ DEPEND="${RDEPEND}
valgrind? ( dev-util/valgrind )
"
-PATCHES=( "${FILESDIR}/${PN}-1.4.1-buildsystem.patch" )
+PATCHES=( "${FILESDIR}/${PN}-1.4.3-buildsystem.patch" )
src_prepare(){
default