summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-05-15 12:36:41 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-05-15 12:55:42 +0200
commit83bd1c499b9fad34a12847cff5ef4690cc011850 (patch)
treeb6834c4b0607f545bdee015ff71a5b9273746e2e /dev-util/mdds
parentdev-lang/mercury-extras: version bump (diff)
downloadgentoo-83bd1c499b9fad34a12847cff5ef4690cc011850.tar.gz
gentoo-83bd1c499b9fad34a12847cff5ef4690cc011850.tar.bz2
gentoo-83bd1c499b9fad34a12847cff5ef4690cc011850.zip
dev-util/mdds: 2.0.3 version bump
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-util/mdds')
-rw-r--r--dev-util/mdds/Manifest1
-rw-r--r--dev-util/mdds/mdds-2.0.3.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-util/mdds/Manifest b/dev-util/mdds/Manifest
index 27e63be07271..22a37a5393f0 100644
--- a/dev-util/mdds/Manifest
+++ b/dev-util/mdds/Manifest
@@ -1,2 +1,3 @@
DIST mdds-1.7.0.tar.xz 313220 BLAKE2B 02ab09ad1338223da2911c05fc8d67c9d0d5414d1dcedac066dc95a2b0853f3801347c9791a5fc5700d666933be78efc52f735453769f9f2123ce06eca1fa67f SHA512 ac2bfe5186d499a79f4379c1dc7cc869bbbd9a59d4943399409dd4dd1ef7e3567a993deda5d5a06ad67dbd94b0a534439805837f2f405c5aca0aeb197178291a
DIST mdds-2.0.2.tar.xz 415824 BLAKE2B 47b720b96fec4a4410dcb15c86c19ddaa502b9d45905905609a28ba9cbb2e6021ce20c82d26e28cd2374e76d779361e1805a7401134c2ee30fd09fbf6ac35d79 SHA512 eba7dc5a5961e69208c8e605995355c0fef392eb4273e8391d529aa9c49b24e491675f443767abef80ff30440bd9fcbaf0f1fbd5bad9c0ecb6b761033efd6f27
+DIST mdds-2.0.3.tar.xz 419884 BLAKE2B bfadf334ccf7695ac0234a9355e5c466e4f8b8fced2b37a4446a3ef899ce28cc9f155223ac5c4ba88ed54886ffd9a38996973195a5120abb886d2e791f596609 SHA512 6600cca5cd2272905dfdeea21a8a1615bb8f15e0c0ae5efec99345b34387cc18fa2aa61ae7142edaddb41738f7386a74a91997ac5ed1a8cfc7cf4b72b0bd2935
diff --git a/dev-util/mdds/mdds-2.0.3.ebuild b/dev-util/mdds/mdds-2.0.3.ebuild
new file mode 100644
index 000000000000..9185efd612ad
--- /dev/null
+++ b/dev-util/mdds/mdds-2.0.3.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://gitlab.com/mdds/mdds.git"
+ inherit git-r3
+else
+ SRC_URI="https://kohei.us/files/${PN}/src/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+fi
+inherit autotools toolchain-funcs
+
+DESCRIPTION="Collection of multi-dimensional data structure and indexing algorithm"
+HOMEPAGE="https://gitlab.com/mdds/mdds"
+
+LICENSE="MIT"
+SLOT="1/2.0" # Check API version on version bumps!
+IUSE="doc openmp valgrind test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ doc? (
+ app-doc/doxygen
+ dev-python/sphinx
+ )
+ valgrind? ( dev-util/valgrind )
+"
+DEPEND="dev-libs/boost:="
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-1.5.0-buildsystem.patch" )
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable doc docs)
+ $(use_enable openmp)
+ $(use_enable valgrind memory_tests)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ tc-export CXX
+ default
+}