summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Beddek <telans@posteo.de>2021-10-31 15:36:30 +1300
committerSam James <sam@gentoo.org>2021-11-14 05:24:31 +0000
commita35a8d18a245de438825c68aeeab5b44375e8abe (patch)
tree4d006bfb5649f50d707599f2ec15bc12cd11b2e9 /dev-util/mdds
parentdev-util/ccache: add 4.5 (diff)
downloadgentoo-a35a8d18a245de438825c68aeeab5b44375e8abe.tar.gz
gentoo-a35a8d18a245de438825c68aeeab5b44375e8abe.tar.bz2
gentoo-a35a8d18a245de438825c68aeeab5b44375e8abe.zip
dev-util/mdds: add 2.0.0
Signed-off-by: James Beddek <telans@posteo.de> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/mdds')
-rw-r--r--dev-util/mdds/Manifest1
-rw-r--r--dev-util/mdds/mdds-2.0.0.ebuild65
-rw-r--r--dev-util/mdds/mdds-9999.ebuild6
3 files changed, 69 insertions, 3 deletions
diff --git a/dev-util/mdds/Manifest b/dev-util/mdds/Manifest
index bbcf1672121a..bd6171d8e4f7 100644
--- a/dev-util/mdds/Manifest
+++ b/dev-util/mdds/Manifest
@@ -1 +1,2 @@
DIST mdds-1.7.0.tar.xz 313220 BLAKE2B 02ab09ad1338223da2911c05fc8d67c9d0d5414d1dcedac066dc95a2b0853f3801347c9791a5fc5700d666933be78efc52f735453769f9f2123ce06eca1fa67f SHA512 ac2bfe5186d499a79f4379c1dc7cc869bbbd9a59d4943399409dd4dd1ef7e3567a993deda5d5a06ad67dbd94b0a534439805837f2f405c5aca0aeb197178291a
+DIST mdds-2.0.0.tar.xz 409984 BLAKE2B 39c8e6946f53d0cb51d1ce9b47c036eae78b0c276e50718f1837836caab3ffa341d8df3908ca332dec3549eb9541a50c1870b17f70b29c46162ff8a721cb10b2 SHA512 bc6b7629d69cb8a685c611e371c998579eea66ac006cfe3d7a39d216714767093832cc0978d1bfb73912c7f200921a44c477dadd311cd6e28586af55ae678f14
diff --git a/dev-util/mdds/mdds-2.0.0.ebuild b/dev-util/mdds/mdds-2.0.0.ebuild
new file mode 100644
index 000000000000..58f1c940cdf9
--- /dev/null
+++ b/dev-util/mdds/mdds-2.0.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://gitlab.com/mdds/mdds.git"
+ inherit git-r3
+else
+ SRC_URI="https://kohei.us/files/${PN}/src/${P}.tar.xz"
+ # Unkeyworded while libreoffice has no release making use of this slot
+ # KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+fi
+inherit autotools toolchain-funcs
+
+DESCRIPTION="Collection of multi-dimensional data structure and indexing algorithm"
+HOMEPAGE="https://gitlab.com/mdds/mdds"
+
+LICENSE="MIT"
+SLOT="1/2.0" # Check API version on version bumps!
+IUSE="doc openmp valgrind test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ doc? (
+ app-doc/doxygen
+ dev-python/sphinx
+ )
+ valgrind? ( dev-util/valgrind )
+"
+DEPEND="dev-libs/boost:="
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-1.5.0-buildsystem.patch" )
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable doc docs)
+ $(use_enable valgrind memory_tests)
+ )
+ if use openmp && tc-has-openmp; then
+ myeconfargs+=( --enable-openmp )
+ else
+ myeconfargs+=( --disable-openmp )
+ fi
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ tc-export CXX
+ default
+}
diff --git a/dev-util/mdds/mdds-9999.ebuild b/dev-util/mdds/mdds-9999.ebuild
index 37a5d8728339..dc57a4506ee2 100644
--- a/dev-util/mdds/mdds-9999.ebuild
+++ b/dev-util/mdds/mdds-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-if [[ ${PV} == *9999 ]]; then
+if [[ ${PV} == *9999* ]]; then
EGIT_REPO_URI="https://gitlab.com/mdds/mdds.git"
inherit git-r3
else