summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2018-07-06 14:45:59 -0500
committerWilliam Hubbs <williamh@gentoo.org>2018-07-06 15:20:28 -0500
commit860674d1ce1ccc8208bbb08823d831312e7a4f74 (patch)
tree54b44c596c9e6e846c77f87ce5fe7dfec7abca9f /dev-util/meson
parentnet-vpn/tinc: version bump to 1.1_pre16 and minor improvements. (diff)
downloadgentoo-860674d1ce1ccc8208bbb08823d831312e7a4f74.tar.gz
gentoo-860674d1ce1ccc8208bbb08823d831312e7a4f74.tar.bz2
gentoo-860674d1ce1ccc8208bbb08823d831312e7a4f74.zip
dev-util/meson: 0.47.0 bump
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-util/meson')
-rw-r--r--dev-util/meson/Manifest1
-rw-r--r--dev-util/meson/meson-0.47.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-util/meson/Manifest b/dev-util/meson/Manifest
index b989ce954170..0d03d3f0b1dd 100644
--- a/dev-util/meson/Manifest
+++ b/dev-util/meson/Manifest
@@ -2,3 +2,4 @@ DIST meson-0.44.1.tar.gz 1136337 BLAKE2B 7391776d2f480f43c6cf0bfae3665c16a61c4a2
DIST meson-0.45.1.tar.gz 1163287 BLAKE2B 820ab763193322c75ebf3a79cd38f49f9fa06f9645f382961eddab9bb088263f5ecc603d3ba6db9e038db1ea150d6897dc202bad24ff985ab1ef2dea3f08b724 SHA512 704731aae28ba5fe4c2040464d42489cfc1946c95c39e28eef170ba5ab929b8672c782ed18798528b59aeb38abd23e4930f38e38f1e8c45f1ccf96071b097731
DIST meson-0.46.0.tar.gz 1200258 BLAKE2B 8f1fdae2456d262abff6078084c8f3ca7a4163e709fe9cdf99fad4b9f42ee42750e66db4dd66728df5c26f2622b9a55388f6c165cbcc022513622df2ebcf7d72 SHA512 f2985bfd19477c2f6cd773d7cd0453084e850c0924e110261dcfe183d1534d9d1098ca032fac050d3913893c94a20a2277daa1c12f0cee4fe368a91d136a0c15
DIST meson-0.46.1.tar.gz 1203731 BLAKE2B 3b6b78e24a4d1ff3166db5546dda80e8b29236babec51fd5f1e70ba4139f13c4e7b6d2985daccf9ef1bc2e33516b1278ab9c9ea4c7fce775d187450c2498dc76 SHA512 beacd5431f9d6abd85a72b2609cbd913f67829b2eef4712a5b9a151e2d0cad6e2c16b5e42819b93f986705305ed874d26211c315aa930b1695552a9e30de8b98
+DIST meson-0.47.0.tar.gz 1246932 BLAKE2B 0191c383488132393fe3e3fb9e71ca0bb0906b8c856bfa72d6352b890246c14bacfe86f4f75c065b0d7197b30570dc63d53d0e7d6a0f25cafe0e85442e89c971 SHA512 02a9aa481c6cce011be9bd3ada523c45f503c70c1c6c8c826241c16a84c8ccbb06de2caced8c748850c24b7a696705c8c72847f935fd720edbd286235390fd94
diff --git a/dev-util/meson/meson-0.47.0.ebuild b/dev-util/meson/meson-0.47.0.ebuild
new file mode 100644
index 000000000000..a02f93d684e4
--- /dev/null
+++ b/dev-util/meson/meson-0.47.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{5,6} )
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/mesonbuild/meson"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x64-macos ~x64-solaris"
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Open source build system"
+HOMEPAGE="http://mesonbuild.com/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+RESTRICT="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+python_test() {
+ ${EPYTHON} run_tests.py || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ insinto /usr/share/vim/vimfiles
+ doins -r data/syntax-highlighting/vim/{ftdetect,indent,syntax}
+ insinto /usr/share/zsh/site-functions
+ doins data/shell-completions/zsh/_meson
+}