summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/mingw-runtime/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/mingw-runtime/files')
-rw-r--r--dev-util/mingw-runtime/files/mingw-runtime-3.12-DESTDIR.patch22
-rw-r--r--dev-util/mingw-runtime/files/mingw-runtime-3.18-gcc-4.6.patch27
-rw-r--r--dev-util/mingw-runtime/files/mingw-runtime-3.20-LDBL_MIN_EXP.patch145
3 files changed, 194 insertions, 0 deletions
diff --git a/dev-util/mingw-runtime/files/mingw-runtime-3.12-DESTDIR.patch b/dev-util/mingw-runtime/files/mingw-runtime-3.12-DESTDIR.patch
new file mode 100644
index 000000000000..f5c52ba6b1e2
--- /dev/null
+++ b/dev-util/mingw-runtime/files/mingw-runtime-3.12-DESTDIR.patch
@@ -0,0 +1,22 @@
+--- Makefile.in
++++ Makefile.in
+@@ -58,5 +58,11 @@
+ endif
+
++inst_bindir:=$(DESTDIR)$(inst_bindir)
++inst_includedir:=$(DESTDIR)$(inst_includedir)
++inst_libdir:=$(DESTDIR)$(inst_libdir)
++inst_docdir:=$(DESTDIR)$(inst_docdir)
++mandir:=$(DESTDIR)$(mandir)
++
+ # The Mingw headers are installed under a subdirectory of
+ # $(tooldir)/include when configuring in Cygwin.
+ HEADER_SUBDIR = @HEADER_SUBDIR@
+@@ -199,6 +199,6 @@
+ all_dlls_host: $(DLLS)
+
+-install_dlls_host:
++install_dlls_host: install-dirs
+ for i in $(DLLS); do \
+ $(INSTALL_PROGRAM) $$i $(inst_bindir)/$$i ; \
+ done
diff --git a/dev-util/mingw-runtime/files/mingw-runtime-3.18-gcc-4.6.patch b/dev-util/mingw-runtime/files/mingw-runtime-3.18-gcc-4.6.patch
new file mode 100644
index 000000000000..8b2418178857
--- /dev/null
+++ b/dev-util/mingw-runtime/files/mingw-runtime-3.18-gcc-4.6.patch
@@ -0,0 +1,27 @@
+http://sourceforge.net/tracker/?func=detail&aid=3446009&group_id=2435&atid=302435
+https://bugs.gentoo.org/419627
+
+--- a/tlssup.c
++++ b/tlssup.c
+@@ -84,6 +84,7 @@ BOOL WINAPI
+ __dyn_tls_init (HANDLE hDllHandle, DWORD dwReason, LPVOID lpreserved)
+ {
+ _PVFV *pfunc;
++ int nfuncs, ifunc;
+
+ /* We don't let us trick here. */
+ if (_CRT_MT != 2)
+@@ -96,8 +97,12 @@ __dyn_tls_init (HANDLE hDllHandle, DWORD dwReason, LPVOID lpreserved)
+ return TRUE;
+ }
+
+- for (pfunc = &__xd_a + 1; pfunc != &__xd_z; ++pfunc)
++ /* Use the nfuncs variable to iterate the TLS functions instead of pfunc to
++ avoid nasty compiler optimizations when comparing two global pointers. */
++ nfuncs = &__xd_z - (&__xd_a + 1);
++ for (ifunc=0; ifunc < nfuncs; ++ifunc)
+ {
++ pfunc = (&__xd_a + 1) + ifunc;
+ if (*pfunc != NULL)
+ (*pfunc)();
+ }
diff --git a/dev-util/mingw-runtime/files/mingw-runtime-3.20-LDBL_MIN_EXP.patch b/dev-util/mingw-runtime/files/mingw-runtime-3.20-LDBL_MIN_EXP.patch
new file mode 100644
index 000000000000..8c409569238d
--- /dev/null
+++ b/dev-util/mingw-runtime/files/mingw-runtime-3.20-LDBL_MIN_EXP.patch
@@ -0,0 +1,145 @@
+http://sourceforge.net/tracker/?func=detail&atid=102435&aid=3441135&group_id=2435
+https://bugs.gentoo.org/395893
+
+????-??-?? Keith Marshall <keithmarshall@...>
+
+ Support pragmatic identification for w32api source directory.
+
+ * aclocal.m4 (MINGW_AC_W32API_SRCDIR): New macro; implement it.
+ * configure.in (W32API_INCLUDE): Assign using MINGW_AC_W32API_SRCDIR.
+ * Makefile.in (W32API_INCLUDE): Prefix -I flag to AC_SUBST value.
+ * mingwex/Makefile.in (W32API_INCLUDE): Likewise.
+ * profile/Makefile.in (W32API_INCLUDE): Likewise.
+
+diff -r 62c176864807 Makefile.in
+--- a/Makefile.in Mon Nov 28 11:32:25 2011 +0000
++++ b/Makefile.in Mon Nov 28 21:18:55 2011 +0000
+@@ -166,9 +166,9 @@ THREAD_DLL_NAME = $(THREAD_DLL)$(THREAD_
+ # Various libraries.
+ LIBM_A=@LIBM_A@
+
+-W32API_INCLUDE = @W32API_INCLUDE@
+-INCLUDES = -I$(srcdir)/include \
+- -I$(srcdir)/../include \
++W32API_INCLUDE = -I @W32API_INCLUDE@
++INCLUDES = -I $(srcdir)/include \
++ -I $(srcdir)/../include \
+ -nostdinc \
+ -iwithprefixbefore include
+ ALL_CFLAGS = $(CFLAGS) $(INCLUDES) $(W32API_INCLUDE)
+diff -r 62c176864807 aclocal.m4
+--- a/aclocal.m4 Mon Nov 28 11:32:25 2011 +0000
++++ b/aclocal.m4 Mon Nov 28 21:18:55 2011 +0000
+@@ -15,7 +15,65 @@ AC_DEFUN([MINGW_AC_CONFIG_SRCDIR],
+ AC_MSG_CHECKING([package version])
+ PACKAGE_VERSION=`awk '$[2] == "'"$1"'" { print $[3] }' ${srcdir}/$2`
+ AC_MSG_RESULT([$PACKAGE_VERSION])dnl
+-]) #MINGW_AC_CONFIG_SRCDIR
++])# MINGW_AC_CONFIG_SRCDIR
++
++# MINGW_AC_W32API_SRCDIR
++# ----------------------
++# Attempt to identify the location of the w32api sources.
++# Accept an explicit location specified by to user, as argument
++# to --with-w32api-srcdir; if unspecified, fall back to standard
++# location relative to ${srcdir}. Identification requires that
++# include/windows.h is present within the nominated directory.
++# This is naive, but AC_CHECK_HEADER cannot be used because
++# the system's w32api headers will interfere.
++#
++AC_DEFUN([MINGW_AC_W32API_SRCDIR],
++[AC_ARG_WITH([w32api-srcdir],
++ [AS_HELP_STRING([--with-w32api-srcdir=DIR],
++ [locate w32api sources in DIR [SRCDIR/../w32api]])
++ ],[],[with_w32api_srcdir=NONE])
++ AS_IF([test "x${with_w32api_srcdir}" = xNONE],
++ [AC_MSG_CHECKING([include path for w32api headers])
++ for with_w32api_srcdir in ${srcdir}/../w32api*; do
++ test -f "${with_w32api_srcdir}/include/windows.h" && break
++ with_w32api_srcdir=NONE
++ done
++ AS_IF([test "x${with_w32api_srcdir}" = xNONE],
++ [AC_MSG_RESULT([none found])
++ AC_MSG_RESULT
++ AC_MSG_WARN([source directory containing include/windows.h not found])
++ AC_MSG_WARN([ensure w32api sources are installed at \${top_srcdir}/../w32api*])
++ AC_MSG_WARN([or use --with-w32api-srcdir=DIR to specify an alternative])
++ ],
++ [case "${with_w32api_srcdir}" in
++ "${srcdir}/"*) with_w32api_srcdir="`echo "${with_w32api_srcdir}"dnl
++ | sed s,"^${srcdir}/",'${top_srcdir}/',`" ;;
++ esac
++ AC_MSG_RESULT([${with_w32api_srcdir}/include])
++ ])
++ ],
++ [AC_MSG_CHECKING([for windows.h in ${with_w32api_srcdir}/include])
++ AS_IF([test -f "${with_w32api_srcdir}/include/windows.h"],
++ [AC_MSG_RESULT([yes])
++ case "${with_w32api_srcdir}" in /*) ;;
++ *) with_w32api_srcdir='${top_builddir}/'"${with_w32api_srcdir}" ;;
++ esac
++ ],
++ [AC_MSG_RESULT([no])
++ AC_MSG_RESULT
++ AC_MSG_WARN([the nominated directory, ${with_w32api_srcdir}])
++ AC_MSG_WARN([does not appear to contain valid w32api source code])
++ AC_MSG_WARN([(file '${with_w32api_srcdir}/include/windows.h' is not present)])
++ with_w32api_srcdir=NONE
++ ])
++ ])
++ AS_IF([test "x${with_w32api_srcdir}" = xNONE],
++ [AC_MSG_WARN([please correct this omission and run configure again])
++ AC_MSG_RESULT
++ AC_MSG_ERROR([unable to continue until this issue is resolved])
++ ])
++ W32API_INCLUDE="${with_w32api_srcdir}/include"
++])# MINGW_AC_W32API_SRCDIR
+
+ # The following is copied from `no-executables.m4', in the top
+ # `src/config' directory.
+diff -r 62c176864807 configure.in
+--- a/configure.in Mon Nov 28 11:32:25 2011 +0000
++++ b/configure.in Mon Nov 28 21:18:55 2011 +0000
+@@ -44,7 +44,7 @@ AC_CHECK_TOOL([WINDRES], [windres], [win
+
+ AC_SUBST([NO_CYGWIN])
+ AC_SUBST([HEADER_SUBDIR])
+-AC_SUBST([W32API_INCLUDE], ['-I ${top_srcdir}/../w32api/include'])
++AC_SUBST([W32API_INCLUDE], [MINGW_AC_W32API_SRCDIR])
+
+ # The following are used by the GCC profiling hooks...
+ #
+diff -r 62c176864807 mingwex/Makefile.in
+--- a/mingwex/Makefile.in Mon Nov 28 11:32:25 2011 +0000
++++ b/mingwex/Makefile.in Mon Nov 28 21:18:55 2011 +0000
+@@ -126,10 +126,9 @@ ifdef NO_CYGWIN
+ override CC := ${NO_CYGWIN} $(firstword $(filter-out ${NO_CYGWIN},${CC}))
+ endif
+
+-W32API_INCLUDE = @W32API_INCLUDE@
+-INCLUDES = -I${srcdir} -I${top_srcdir} -I${top_srcdir}/include \
+- -nostdinc \
+- -iwithprefixbefore include
++W32API_INCLUDE = -I @W32API_INCLUDE@
++INCLUDES = -I ${srcdir} -I ${top_srcdir} -I ${top_srcdir}/include \
++ -nostdinc -isystem @W32API_INCLUDE@ -iwithprefixbefore include
+ ALL_CFLAGS = $(CFLAGS) $(WARNFLAGS) $(OPTFLAGS) $(INCLUDES) $(W32API_INCLUDE)
+ ALL_CXXFLAGS = $(CXXFLAGS) $(WARNFLAGS) $(OPTFLAGS) $(INCLUDES) -nostdinc++ $(W32API_INCLUDE)
+
+diff -r 62c176864807 profile/Makefile.in
+--- a/profile/Makefile.in Mon Nov 28 11:32:25 2011 +0000
++++ b/profile/Makefile.in Mon Nov 28 21:18:55 2011 +0000
+@@ -65,10 +65,9 @@ THREAD_DLL = @THREAD_DLL@
+ THREAD_DLL_VERSION = 10
+ THREAD_DLL_NAME = $(THREAD_DLL)$(THREAD_DLL_VERSION).dll
+
+-W32API_INCLUDE = @W32API_INCLUDE@
+-INCLUDES = -I${srcdir} -I${top_srcdir}/include \
+- -nostdinc \
+- -iwithprefixbefore include
++W32API_INCLUDE = -I @W32API_INCLUDE@
++INCLUDES = -I ${srcdir} -I ${top_srcdir}/include \
++ -nostdinc -iwithprefixbefore include
+ ALL_CFLAGS = $(CFLAGS) $(INCLUDES) $(W32API_INCLUDE)
+ ALL_CXXFLAGS = $(CXXFLAGS) $(INCLUDES) -nostdinc++ $(W32API_INCLUDE)
+