summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/mingw-runtime/mingw-runtime-4.0.3.1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/mingw-runtime/mingw-runtime-4.0.3.1.ebuild')
-rw-r--r--dev-util/mingw-runtime/mingw-runtime-4.0.3.1.ebuild84
1 files changed, 84 insertions, 0 deletions
diff --git a/dev-util/mingw-runtime/mingw-runtime-4.0.3.1.ebuild b/dev-util/mingw-runtime/mingw-runtime-4.0.3.1.ebuild
new file mode 100644
index 000000000000..dea6916c28cb
--- /dev/null
+++ b/dev-util/mingw-runtime/mingw-runtime-4.0.3.1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+export CBUILD=${CBUILD:-${CHOST}}
+export CTARGET=${CTARGET:-${CHOST}}
+if [[ ${CTARGET} == ${CHOST} ]] ; then
+ if [[ ${CATEGORY} == cross-* ]] ; then
+ export CTARGET=${CATEGORY#cross-}
+ fi
+fi
+
+inherit flag-o-matic toolchain-funcs versionator
+
+MY_P="mingwrt-$(version_format_string '$1.$2.$3-$4')-mingw32"
+DESCRIPTION="Free Win32 runtime and import library definitions"
+HOMEPAGE="http://www.mingw.org/"
+# http://sourceforge.net/projects/mingw/files/MinGW/Base/mingw-rt/
+SRC_URI="mirror://sourceforge/mingw/${MY_P}-src.tar.lzma"
+
+LICENSE="BSD"
+SLOT="0"
+# Collides with w32api-4.x
+#KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="crosscompile_opts_headers-only"
+RESTRICT="strip"
+
+DEPEND="app-arch/xz-utils"
+RDEPEND=""
+
+S=${WORKDIR}/${MY_P}-src
+
+is_crosscompile() {
+ [[ ${CHOST} != ${CTARGET} ]]
+}
+just_headers() {
+ use crosscompile_opts_headers-only && [[ ${CHOST} != ${CTARGET} ]]
+}
+
+pkg_setup() {
+ if [[ ${CBUILD} == ${CHOST} ]] && [[ ${CHOST} == ${CTARGET} ]] ; then
+ die "Invalid configuration"
+ fi
+}
+
+src_prepare() {
+ sed -i \
+ -e '/^install_dlls_host:/s:$: install-dirs:' \
+ Makefile.in || die # fix parallel install
+}
+
+src_configure() {
+ just_headers && return 0
+
+ CHOST=${CTARGET} strip-unsupported-flags
+ filter-flags -frecord-gcc-switches
+ tc-export AR
+ econf \
+ --host=${CTARGET} \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}"
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ if just_headers ; then
+ insinto /usr/${CTARGET}/usr/include
+ doins -r include/*
+ else
+ local insdir
+ is_crosscompile \
+ && insdir="${D}/usr/${CTARGET}" \
+ || insdir="${D}"
+ emake -j1 install DESTDIR="${insdir}"
+ env -uRESTRICT CHOST=${CTARGET} prepallstrip
+ rm -rf "${insdir}"/usr/doc
+ docinto ${CTARGET} # Avoid collisions with other cross-compilers.
+ fi
+ is_crosscompile && dosym usr /usr/${CTARGET}/mingw
+}