summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-05-13 22:13:36 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-05-13 22:21:58 -0400
commitc7a42f71ba83ce97eeae0ed50b0ab334f667c720 (patch)
tree18fdedebbe3650a66fe63872ba076f1861f0baf9 /dev-util/mingw64-runtime
parentapp-emulation/vkd3d-proton: add bypass for crossdev checks / unset (diff)
downloadgentoo-c7a42f71ba83ce97eeae0ed50b0ab334f667c720.tar.gz
gentoo-c7a42f71ba83ce97eeae0ed50b0ab334f667c720.tar.bz2
gentoo-c7a42f71ba83ce97eeae0ed50b0ab334f667c720.zip
dev-util/mingw64-runtime: add bypass option for unset
Unset is needed given CC is not expected to be a cross-compiler but, if users know what they are doing, leave a way (MINGW_BYPASS=1). Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-util/mingw64-runtime')
-rw-r--r--dev-util/mingw64-runtime/mingw64-runtime-10.0.0-r1.ebuild2
-rw-r--r--dev-util/mingw64-runtime/mingw64-runtime-8.0.0-r3.ebuild2
-rw-r--r--dev-util/mingw64-runtime/mingw64-runtime-9.0.0-r2.ebuild2
3 files changed, 3 insertions, 3 deletions
diff --git a/dev-util/mingw64-runtime/mingw64-runtime-10.0.0-r1.ebuild b/dev-util/mingw64-runtime/mingw64-runtime-10.0.0-r1.ebuild
index d082ba67bbc6..76ea7da69341 100644
--- a/dev-util/mingw64-runtime/mingw64-runtime-10.0.0-r1.ebuild
+++ b/dev-util/mingw64-runtime/mingw64-runtime-10.0.0-r1.ebuild
@@ -58,7 +58,7 @@ src_configure() {
MW_LDFLAGS=${LDFLAGS} # keep non-stripped for gendef not respecting it
# likely cross-compiling from here, update toolchain variables
- ${MW_CROSS} &&
+ ${MW_CROSS} && [[ ! -v MINGW_BYPASS ]] &&
unset AR AS CC CPP CXX LD NM OBJCOPY OBJDUMP RANLIB RC STRIP
local CHOST=${CTARGET}
strip-unsupported-flags
diff --git a/dev-util/mingw64-runtime/mingw64-runtime-8.0.0-r3.ebuild b/dev-util/mingw64-runtime/mingw64-runtime-8.0.0-r3.ebuild
index 7eaca692a9d3..faedf8c7e909 100644
--- a/dev-util/mingw64-runtime/mingw64-runtime-8.0.0-r3.ebuild
+++ b/dev-util/mingw64-runtime/mingw64-runtime-8.0.0-r3.ebuild
@@ -60,7 +60,7 @@ src_configure() {
MW_LDFLAGS=${LDFLAGS} # keep non-stripped for gendef not respecting it
# likely cross-compiling from here, update toolchain variables
- ${MW_CROSS} &&
+ ${MW_CROSS} && [[ ! -v MINGW_BYPASS ]] &&
unset AR AS CC CPP CXX LD NM OBJCOPY OBJDUMP RANLIB RC STRIP
local CHOST=${CTARGET}
strip-unsupported-flags
diff --git a/dev-util/mingw64-runtime/mingw64-runtime-9.0.0-r2.ebuild b/dev-util/mingw64-runtime/mingw64-runtime-9.0.0-r2.ebuild
index d082ba67bbc6..76ea7da69341 100644
--- a/dev-util/mingw64-runtime/mingw64-runtime-9.0.0-r2.ebuild
+++ b/dev-util/mingw64-runtime/mingw64-runtime-9.0.0-r2.ebuild
@@ -58,7 +58,7 @@ src_configure() {
MW_LDFLAGS=${LDFLAGS} # keep non-stripped for gendef not respecting it
# likely cross-compiling from here, update toolchain variables
- ${MW_CROSS} &&
+ ${MW_CROSS} && [[ ! -v MINGW_BYPASS ]] &&
unset AR AS CC CPP CXX LD NM OBJCOPY OBJDUMP RANLIB RC STRIP
local CHOST=${CTARGET}
strip-unsupported-flags