summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-05-27 11:19:18 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-05-28 15:26:07 -0400
commit864b148cbfd35252de45e48beb2704b4675044ae (patch)
treeed3d98f08aa0046093e0ad7e8d7e41f1d2b0308e /dev-util/mingw64-toolchain
parentmedia-sound/pulseaudio: Version bump to 16.0 (diff)
downloadgentoo-864b148cbfd35252de45e48beb2704b4675044ae.tar.gz
gentoo-864b148cbfd35252de45e48beb2704b4675044ae.tar.bz2
gentoo-864b148cbfd35252de45e48beb2704b4675044ae.zip
dev-util/mingw64-toolchain: fix array check
Unimportant given variables are prefixed and unlikely users set any of these (check is to ignore envionment), but was wrong anyway. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-util/mingw64-toolchain')
-rw-r--r--dev-util/mingw64-toolchain/mingw64-toolchain-10.0.0.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-util/mingw64-toolchain/mingw64-toolchain-10.0.0.ebuild b/dev-util/mingw64-toolchain/mingw64-toolchain-10.0.0.ebuild
index e0569a0e7981..5347cee7ffdc 100644
--- a/dev-util/mingw64-toolchain/mingw64-toolchain-10.0.0.ebuild
+++ b/dev-util/mingw64-toolchain/mingw64-toolchain-10.0.0.ebuild
@@ -203,8 +203,8 @@ src_compile() {
# mostly unused here, so use configure directly
eval '
local conf=( "${WORKDIR}/${1}"/configure "${conf[@]}" )
- [[ ${conf_'${id}'@a} ]] && conf+=( "${conf_'${id}'[@]}" )
- [[ ${2} && ${conf_'${id}_${2}'@a} ]] && conf+=( "${conf_'${id}_${2}'[@]}" )
+ [[ ${conf_'${id}'@a} =~ a ]] && conf+=( "${conf_'${id}'[@]}" )
+ [[ ${2} && ${conf_'${id}_${2}'@a} =~ a ]] && conf+=( "${conf_'${id}_${2}'[@]}" )
conf+=( ${EXTRA_ECONF} ${MWT_'${id^^}'_CONF} )
[[ ${2} ]] && conf+=( ${MWT_'${1^^}_${2^^}'_CONF} )'