summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/mock
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/mock')
-rw-r--r--dev-util/mock/Manifest1
-rw-r--r--dev-util/mock/metadata.xml7
-rw-r--r--dev-util/mock/mock-1.0.3.ebuild28
3 files changed, 36 insertions, 0 deletions
diff --git a/dev-util/mock/Manifest b/dev-util/mock/Manifest
new file mode 100644
index 000000000000..5da79979fa4c
--- /dev/null
+++ b/dev-util/mock/Manifest
@@ -0,0 +1 @@
+DIST mock-1.0.3.tar.gz 237654 SHA256 7b0c29920f97d4cf51d9f29eb4728e514eadfefea3b8d9888f228bc91f97eb54 SHA512 da95fd3a43236f6919416c66d49467daaf0562d7d4e06c4ab9f8a9e4906e9f6e5ac4c5cab4638d2d2ec6dbbc6a3f2a6c2d0436347aeaa553c6dd57daf0212eab WHIRLPOOL 2ffafd13560988b4d8185d28eccac3c04f8c2ba2b910590d3f229013d211723a5b05253a74559281ec0d0d6badd5211af57e198505910110b48b59a0291a234c
diff --git a/dev-util/mock/metadata.xml b/dev-util/mock/metadata.xml
new file mode 100644
index 000000000000..d9cd2cad66c2
--- /dev/null
+++ b/dev-util/mock/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>maintainer-needed@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-util/mock/mock-1.0.3.ebuild b/dev-util/mock/mock-1.0.3.ebuild
new file mode 100644
index 000000000000..d500c3055f1a
--- /dev/null
+++ b/dev-util/mock/mock-1.0.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils user
+
+DESCRIPTION="create chroots and build packages in them for Fedora and RedHat"
+HOMEPAGE="http://fedoraproject.org/wiki/Projects/Mock"
+SRC_URI="https://fedorahosted.org/mock/attachment/wiki/MockTarballs/mock-${PV}.tar.gz?format=raw -> mock-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="sys-apps/yum
+ dev-python/decoratortools"
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+}
+
+pkg_postinst() {
+ enewgroup mock
+}